Fog Creek Software
Discussion Board

AvantGo and this forum

I have AvantGo (on my Palm device) set up to synch to this forum daily. I have used this in the past to read up on the posts while offline, away from my PC. Here is how I've set up the AvantGo channel:

    Title:     Joel on Software - Discussion
    Maximum Channel Size: 100k
    Link Depth: 2
    Include Images: No
    Follow Off-Site Links: No
    Channel Refresh
    Refresh this channel: on every sync

Recently (over the last several weeks, at least), I find that this doesn't work. I can see the list of topics, but when I click on one, I am taken to a page that says something like, "Article #0 does not exist." (I'm not sure of the exact wording, but it's something like that.) Note that this is not an AvantGo error message -- it's formatted as a JOS page, including the Add a Comment and Recent Links links.

The synch is clearly working, since I get the list of topics AND the pages with the error messages are from JOS. But somehow the JOS page I would see by clicking on this page online is not the same page I see when I click the link on my PDA. Any ideas on what changed, and how I can make this work again?

Monday, February 16, 2004

joel and his elves delete threads for various reasons, so I suspect what is happening is that your program is caching the forum threads as they exist at moment x, then joel is deleting a thread or two, and then you are trying to read them.

I get what sounds like the same error message on the (very occasional) times that Im actively writing a message for a thread while that thread is deleted, when I finish writing I hit the "Post Message" button and get back the "this thread does not exist or has been deleted" (or something along those lines) message.

its an interesting point though, Joel is obviously disrupting more than the immediate environment when he deletes these things.

Monday, February 16, 2004

I get the same problem too on my avantgo subscription for this forum.

Matthew Lock
Monday, February 16, 2004

FullName - I guess it's possible that the deletion of threads causes this problem, but that seems odd since the synch is so quick. AvantGo takes about 2 minutes to do all of my synching, and JOS is a pretty small part of that (maybe 1/6 of the total in volume). So I'd be surprised if I was consistently running into a problem with Joel deleting a thread as I read it. It also happens with every single thread, not just isolated ones.

Matthew - I'm wondering if the parameters I've set up the channel with are to blame. For instance, maybe the 100K is too small, and that throws something off. Or maybe it's the offsite links setting -- maybe Joel now somehow redirects links to some other site and that hoses me up. Can you take a look at the parameters I've posted above and compare them to what you use? Thanks!

Monday, February 16, 2004

I think you now have to pay some $1.5K/year to distribute your content via AvantGo, and maybe Joel deemed it not worth it. Am I wrong?

Big Fan of Fortran
Monday, February 16, 2004

I'm seeing this as well.

Perhaps its because Joel has "&" in his URLs?  Try it - look at the source and copy the URL as-is into the address bar in IE and you end up with the same error message.  (Or is IE putting these in when I do a View/Source?)

Another possibility is that the avantgo client doesn't like semi-colons in the address, and only grabs up to the first semi-colon.

Of course, these are just guesses, as I have no idea how the avantgo client works, and I have no idea if Joel has changed his URL syntax at any point in time.

Monday, February 16, 2004

"Perhaps its because Joel has "&" in his URLs?"

That's the only legal format. If your URL has an & in it, it must be escaped to &. If you don't believe, try validating a page with a link with & in it instead of &.

Brad Wilson (
Monday, February 16, 2004

Umm, yeah, I knew that.  I was just checking to see if anybody would point that out.

Okay, nevermind.

Monday, February 16, 2004

I've now tried fixing this by changing the parameters on my channel definition, but no combination seems to work. Help me out, Joel!

Tuesday, February 17, 2004

*  Recent Topics

*  Fog Creek Home