Fog Creek Software
Discussion Board

Task Manager Problem.

MY laptop is running on Windows 2000 Professional.

The problem is whenever I try to open Task Manager (using ALT + CTRL + DEL > then Task Manager or CTRL + SHIFT + ESC) it pops up for a second and then disappears.

I ran gpedit.msc and checked User Config > Admin Templates > System > Logon/ Logoff - everything looks alright here, the settings are configured to "Not Configured"

Any help would be appreciated.


Prakash S
Wednesday, February 12, 2003

What happens if you do a right mouse button click on the appropriate spot in the lower right corner of the task bar?

Mitch & Murray (from downtown)
Wednesday, February 12, 2003

same thing, it disappears.

Prakash S
Wednesday, February 12, 2003

I've heard (but have no proof) that this is a symptom of the Yaha virus.

Symantec Removal Tool:

I'd be curious to know if this was it.


Jeffrey MacDonald
Thursday, February 13, 2003

Sounds like the Klez virus as well.  Have a look for "winkajp.exe", "winkcc.exe", and "winkvw.exe".  If you have them then you can get a removal tool from the usual anti-virus folk.

Simon Lucy
Thursday, February 13, 2003

tried yaha, klez & other virus removal, no can do!!!

will let you guys know if anything works.

Prakash S
Thursday, February 13, 2003


On Second thoughts, it was yaha, ...

yaha does a whole bunch of crap which includes not allowing you to install antivirus s/w, etc...

had to delete 3 files winservices.exe, nav32_loader.exe, tcpsvc32.exe, back in business now

thanks guys!

Prakash S
Friday, February 14, 2003

You should look into not running as admin and running as a bog-standard user. Much cheaper than AV software and it can also save you from yourself sometimes. You can use the RunAs command ("runas /noprofile /user:MyAdminAccount somecommand") to briefly do things as an admin.

Oh, and stop opening those dodgy emails ;-)

Duncan Smart
Friday, February 14, 2003

Thanks Duncan, I will keep those things about email in my mind:-)

Prakash S
Friday, February 14, 2003

On not running as admin:

I tried that last week. I was rebuilding my desktop box anyway, so I figured I'd "do the right thing" and not run with admin privs.


Office 2k wouldn't run - it got into one of those stupid "windows installer loops" and refused to start. When running as admin, it works fine.

Just about every program I installed needed admin privs. And if I use "runas" to install it as admin, well, guess what - it installs it for the admin user, not all users. ARGH!

It's a great idea in theory, but in my experience Windows systems are unusable as general machines without admin privs.

Hopefully now that I'm aware of this, I won't keep contributing to the problem.

Chris Tavares
Friday, February 14, 2003


I think it's "by design" that apps don't install under regular user accounts. Users don't have write access to %ProgramFiles% for a start.

As for doing a RunAs to install them - I'd say that for installation of apps, as you've found, I'd go for a "full" logon as admin, ie, not use RunAs. Then when they're installed log back in as the regular user a/c.

Like you, I found that when you do an Office install, the annoying MSI Installer kicks into life the first time you run as that user, and then goes away after that... but yes I'm not surprised you've had problems with it - MSI is the most overcomplicated piece of crap...

This guy's got a list of popular apps saying wherther or not they work:

Here's the orginal inspiration:

Here's a "su" script I put in my Windows directory:
  @runas /noprofile /user:AdminDunc "cmd /C start /B %1"
So I just go WinKey+R then "su somecomand" ENTER

Keep trying ;-)

Duncan Smart
Friday, February 14, 2003

I have the same problem.  Yaha, Klez, sasser, i tried removal tools on every virus ever made and nothing comes up.  I have symantec client security, which runs even with the problem of not being able to open task manager, regedit, msconfig, or ad-aware.  Symantec says there is no virus.  If you rename the .exe files that won't open, they will open.  I ran Ad-Aware by doing this and it worked, but it did not find anything really suspicious.  I have tried absolutely everything except reformatting.  Does anyone have any ideas?

Tuesday, May 25, 2004

*  Recent Topics

*  Fog Creek Home