Fog Creek Software
Discussion Board

Welcome! and rules

Joel on Software

Can't create Web applications

Though I have been working on my office machine with .NET for over a year, I recently installed VS.NET 2003 on my home computer some weeks ago. Today I wanted to practice Web Applications in ASP.NET, but I got this error:

Visual Studio .NET has detected that the specified Web Server is not running ASP.NET version 1.1. You will be unable to run ASP.NET Web applications or services.

I clearly remember having installed all the pre-requisites before installing VS.NET. What I do not remember is if I uninstalled IIS and re-installed it after installing VS.NET 2003. The IIS MMC Snap-in shows IIS 5.0 instead of IIS 6.0, which I believe is there on my system.

What do I do?

Sathyaish Chakravarthy
Friday, February 18, 2005

I had something similar & the following fixed it for me:

Jon Spokes
Friday, February 18, 2005

Thank you. I followed the steps in that KB article and here's what I have after a restart.

When I run VS.NET again, I get this message now:

The Web Server reported the following error when attempting to create or open the Web project located at the following URL: 'http://localhost/OrderManagement'. 'HTTP/1.1 500 Server Error'.

My MMC Snap-in still shows IIS 5.1 to be running and not IIS 6.0.

Sathyaish Chakravarthy
Sunday, February 20, 2005

The IIS version is irrelevant (although if you have 5.1 I assume you are using XP), ASP.NET 1.1 runs on 5, 5.1 and 6. However, you may need to repair ASP.NET as the KB article suggests (using the aspnet_regiis tool). But make sure it's the right version - for 1.1 that version path is "v1.1.4322".

You might also want to look at this:

Monday, February 21, 2005

I have this exact error, with no luck form doing the MS recommended fix "aspnet_regiss -i", and regsvr32 aspnet_isapi.dll.

If I can't find a simple fix, I might have to rebuild my development machine.  Eek.

Anyone else having this problem?

Dennis Bottaro
Monday, February 21, 2005

Have you tried installing the .NET Framework 1.1 again? We had the very same issue and we did a "repair" on the framework and that didn't work. We reinstalled the Framework from scratch and the error went away

Tuesday, February 22, 2005

*  Recent Topics

*  Fog Creek Home