Fog Creek Software
Discussion Board

Welcome! and rules

Joel on Software

.Net Apps can't find System.Windows.Forms?

This is a very strange problem that i'm having that manifested itself in only 2 .net applications so far:
1. Newsgator, when right clicking an rss link in a web page and selecting Subscrive in Newsgator, it crashes. Adding the feed manually works fine.
2. .Net Reflector (, which crashes on the very start in a win2k pro up to date (that is also a dev machine), but works just fine on an xp pro that isn't up to date.

The crash is similar in both cases: a System.IO.FileNotFoundException is thrown, and when starting a debug, it gives a message that it can't find the System.Windows.Form assembly.

I've tried uninstalling and reinstalling the .net framework, but to no avail. The strange thing is that it works on xp pro and not on win2k pro... it might be related to a different problem that i'm having, that .net apps that i'm writting, work fine on my win2k pro machine, but crash on win xp (i think it might be the same error, but i haven't tested it yet)

I'm hoping someone here has an idea or encountered something like this before...

GD (
Friday, September 24, 2004

Ok, made some progress... apparently the CLR 1.1 and the CLR 1.0 are quite different... so i'm using CLR 1.1, but i only have v1.1 dlls installed (the ones with 1.0.5000.0), so when i added the System.Windows.Forms from v1.0.3705 to the CLR 1.1 from the control panel, i'm still getting an exception, but now it looks for System only, so i'm probably going to have to figure out the dependencies and add them.

Thanks for trying to help me, and sorry for the bother :)

GD (
Friday, September 24, 2004

*  Recent Topics

*  Fog Creek Home