Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

FTP error - Couldn't put file:

When trying to ftp my feeble initial attempts to my host's webserver I get an FTP error message:

"Couldn't put file: The server returned extended information."

This particular hosting company tells me to FTP my files into the /html directory.  When I look at the FTP site it has the normal FrontPage extensions and two directories /database and /html.

I've successfully FTP'd to an site so I'm thinking there is some conflict on the server side.  Any help would be appreciated.

Guy Bjerke

Guy Bjerke
Sunday, December 16, 2001

What are your FTP settings set to? 

Have you tried turning on(off) passive mode?

After looking at your FTP properties try typing this into IE:

inputting the proper username, password, hostname and subdir for your particular site.

If that doesn't work, then something must be wrong with your settings.

If it doesn work, then we should be able to figure out how to get it to work in CityDesk.

Michael Pryor
Sunday, December 16, 2001

Michael, this is what MS thinks is a reasonable error message. In most cases it really means "file (directory) not found" , "system too busy" or "cannot use passive mode". In my own experiences it's 70% passive mode issues.

Actually this might be one error that might be worth trapping out and then providing a more in-depth error. This message is one of the most freqently asked support questions for most commercial sites.

Read all about it:;EN-US;q156770

Maury Markowitz
Sunday, December 16, 2001


My FTP settings:
Port 21 (default?)
/html  (subdirectory) (preview)
Passive Mode on

I've tried it with passive mode on or off.  I've tried it with and without a subdirectory.

I can reach the site throught IE - that's how I know what's there.  Using IE 5.5.  By the way the FrontPage extensions are in the /html subdirectory - I may have infered differently in earlier post.

I had beta 4 installed, but uninstalled it and re-installed the Starter difference in result.

Thanks for your help.

Guy Bjerke
Sunday, December 16, 2001

We can try to reproduce what is going on by following these steps EXACTLY.  (They are sorta complicated so you have to follow them exactly!)

1. Start->Run->"command" to get a DOS prompt.
2. type "notepad test.html"
3. In Notepad, type "This is a test."
4. Save and Close Notepad.
5. Go back to command prompt.
6. Type "ftp"
7. When prompted for username and password, enter them.
8. After being logged in type "cd /html"
9. Type "put test.html"
10.  Try to preview test.html using the URL

A thought:
Since you didn't specify what your hostname is I can't be sure of this, but I suspect that setting your ftp server to may be incorrect.  It may be a different machine than  You just may never have had to deal with it because you've been using Frontpage extensions before... but maybe not.  Anyway the test above should clarify if that is the case.

Michael Pryor
Monday, December 17, 2001


Thanks for your patience.  I tried your test.  Everything went fine until step 8 when I tried to change to the /html directory - I was given a 550 - Access denied error message.  I did steps 9 and 10 anyway.

When I looked at the ftp site the test.html was there, just not in the /html directory.

I then reconfigured my publish location in CityDesk without the /html subdirectory and voila' it worked.  Except now it won't recognize the index.html...I'm guessing because it's not in the /html directory.

By the way - this was a clean site.  I've never used FrontPage on it and the extensions were automatically setup.

I think I need to speak to the hosting service to find out why I can't access the /html directory.  Looks like that's my problem - nothing wrong with CityDesk.

Thank you for your help.  Any other thoughts you may have are appreciated.

Guy Bjerke
Monday, December 17, 2001

Exchange "/html" for "html" and re-try.

If this works, then the explanation is longer than is worth typing. :)

Brad Wilson
Monday, December 17, 2001

For two reasons, Brad's idea could be correct.

1 is that the beta version had a bug with slashes in the subdir (/html for example), but I didn't remember until just now.
2 is that ftp servers are weird and like Brad said, its too long to explain.

Michael Pryor
Monday, December 17, 2001

Thank you, Brad & Michael!  Losing the slash worked!  When I make a little more progress with the site I'll forward the url to Terry for addition to the CityDesk site list.

Again, thanks.

Guy Bjerke
Monday, December 17, 2001

*  Recent Topics

*  Fog Creek Home