Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Beta 2 !

Beta 2 is shipping.

If you downloaded Beta 1, you should have gotten an email already with instructions for downloading Beta 2.

We're going to add another couple of hundred beta testers tomorow, on the theory that this version has fewer bugs, so we should get less bug reports, and so we need more beta testers to keep ourselves busy at the same rate. :/

Don't look for too many new features. Our emphasis has been on fixing bugs, not adding features. There are a smattering of tiny new features:

* passive FTP ("don't get me started!")
* options for the toolbar (small/large icons with or without text)
* word wrap in the HTML editor
* use your favorite external editor by right-clicking and choosing any program you like (not just the ones Windows knows about)
* a few recently-opened sites are in the FILE menu

Many of the bugs we fixed were configuration issues. We work a lot better on NT 4.0 now.

All in all, we closed 100 bugs. Thanks for all your help in finding them!

Joel Spolsky
Thursday, November 1, 2001

Easily editing with FrontPage is wonderful.

Larger print in the HTML editor makes things much more pleasant.  Recent files will save me some unecessary thinking and eye strain.

Having the publish window, FTP password, and progress windows in one place on the screen is nice.  Showing the FTP commands scroll down the progress window - well - I think it's OK for y'all to show off that you got "passive FTP" working.

This is better.

Terry Kearns
Thursday, November 1, 2001

One more neato feature that we added for this beta ... you can now sort the contents of a folder alphabetically by right-clicking on the folder.

Joel Spolsky
Friday, November 2, 2001

This is my first installation of Citydesk, and when I tried to run it gaves me the following message:

    System Error &H80004005 (-2147467259)

I only can assume that's some funny VB error caused for some runtime libraries or something. So I checked google (using the site: tip) and found the following article:

It babbles something about a richedit control and even provides a link to download a small app that it's suppossed (sp?) to fix the thing. The funny part is the app spits the following error:

    System Error &H80004005 (-2137467259)

Ok, here we go again. I found another article in the Microsoft Knowledge Base with the title

BUG: "Unspecified error" When Running VB Program That Hosts an ATL Control (

But this time I can't solve the problem, because the solution is intended to developers.

So now I'm installing VB runtime files and see if it solves anything.

Leonardo Herrera
Friday, November 2, 2001

Ok, I rebooted my machine and, just in case, ran riched.exe again. This time, it told me that my version was just fine.

Just one thing: the icons in the initial screen (the "new", "open", "tutorial", etc) needs to go. The ones in the application looks good, thought.

Now I'll start using _the thing_.

Leonardo Herrera
Friday, November 2, 2001

that's a weird one. we're looking into it here. If you get any more hints as to what's causing it, let me know.

* did CityDesk setup ask you to reboot? did you?
* what version of Windows and IE do you have installed?
* do you have Office installed?

Joel Spolsky
Friday, November 2, 2001

Microsoft Windows 98 4.10.1998 
IE 5 5.50.4134.0600
Microsoft Word 2000 (9.0.3821 SR-1)

All spanish versions.

Citydesk's installation didn't asked me to reboot. I didn't.

Probably it's a good idea to force a system reboot when setup is finished...

Leonardo Herrera
Friday, November 2, 2001

It's official.  CityDesk Beta 2 does not like me.

I installed citydesk on my home machine and rebooted as it asked.  On bootup I got a system exception I've never seen before or since on my machine:

IS-NUSPA caused an exception c0000006H in module KERNEL32.DLL at 0167:bff86e9c.
EAX=69bf1000 CS=0167 EIP=bff86e9c EFLGS=00000202
EBX=816e0001 SS=016f ESP=0063fa68 EBP=0063faf0
ECX=00000010 DS=016f ESI=00000000 FS=2227
EDX=c14bb8f0 ES=016f EDI=00000000 GS=0000
Bytes at CS:EIP:
66 8b 48 0e 83 c0 10 66 8b 50 fc 89 45 a4 8b 45
Stack dump:
00000000 816ebc68 816eb988 000e1000 00021e18 00000000 00000000 00000000 00000000 00103000 0000d634 000d3ef0 00000000 00000000 00000000 00000000

I then created citydesk and created a new project, naming it "test".  Now when I click "preview" or "publish", the error reporting wizard pops up.  Happens every time.  This is the info it would have sent to you:

V:1.0 ActiveX component can't create object: 429
frmPublish: HandlePublishClick: 1870
Windows Version: MSFT Windows 98Version 4.10 (Build 67766222)
IE Version: IE 5.0.2314.

My Office version is Office 2000 (MS Word build 9.0.2720).

I would have sent you this through the wizard, except that, when I click send, ANOTHER error wizard box pops up, an infinite loop.  Same information except the location has changed:

frmScout:scout_Success: 1030

My guess is some ActiveX component didn't register right when I rebooted my machine, causing that first exception, and now citydesk is hosed when it wants to create it.

I also once got another system exception, but I can't duplicate it.  It happened when I created a new article under "Articles" and tried to double-click it.

CITYDESK caused an invalid page fault in
module MSCOMCTL.OCX at 0167:2758266c.
EAX=00807a80 CS=0167 EIP=2758266c EFLGS=00010212
EBX=66024468 SS=016f ESP=009ef464 EBP=009ef488
ECX=a0000169 DS=016f ESI=6601a398 FS=0ddf
EDX=009ef490 ES=016f EDI=007d5c50 GS=0000
Bytes at CS:EIP:
ff 11 c2 0c 00 00 00 00 00 00 00 00 00 00 00 00
Stack dump:
00807a80 6601a398 009ef490 6604568c 007fdcf8 6601a398 009ef490 660241e0 007c35cc 009ef530 0061cd0a 007fdd34 007d5c50 009ef54c 009ef5dc 00000001

Saturday, November 3, 2001

I have no idea what IS-NUSPA is... Google and AltaVista search finds nothing :/ THAT'S weird.

As for the second crash... this is caused by not having the right version of Microsoft XML libraries on your machine. Which means there's something wrong about our setup program that installs them. (Did Beta 1 work on this machine? I don't think we've changed anything about XML so I would be surprised if Beta 1 worked but Beta 2 didn't, on that particular machine).

The "frmScout:scout_Success: 1030" is also caused by not have XML.

Please try installing XML from this location:

and let us know if that fixes those problems.

Finally, the COMCTL crash... we have been pursuing that one with great gusto (that is why I am awake at 4 am, in fact) and I think you may have provided us with some valuable clues. Bravo :) Thanks :) Rest assured that it is fairly rare and most everything else will work most of the time once you get XML installed.

Joel Spolsky
Saturday, November 3, 2001

Quick question: can you email me the version of three files that you have?
These files are usually in your Windows or Windows\System or Windows\System32 directory, and you can find out the version number by right-clicking it and choosing Version.

Joel Spolsky
Saturday, November 3, 2001

*  Recent Topics

*  Fog Creek Home