Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

User reported bug in copy/paste

We've had a user report that when he copies and pastes an article it doesn't set the template correctly.  Unfortunately I cannot repro this behaviour and I was wondering if anyone else has any information on this?

Here's the report:
"When I do a Ctrl-C Ctrl-V on an article, I get an article named "Copy of ..." in the right place in the CityDesk explorer.

But... not all of the new article properties are correctly set. In particular, the "template" property is set to the site's default template on the copy. "

Michael H. Pryor
Wednesday, January 30, 2002

I tried it.  The template stayed the same.  But, longer filenames didn't do what I expected.

The original filename was:
Tip: multilingual variable workaround

The file name of the copy became:
Tip  multilingual variable workaround

The colon was replaced by a space gone and no "copy of"

For the file:
Non-breaking spaces - manging spaces and "nbsp"
The copy became:
Non-breaking spaces - manging spaces and  nbsp

The quotation marks are gone and no "copy of"

When I copied a file with a shorter filename it worked as I expected:
"Use a template family"
"Copy of Use a template family"

That just doesn't seem right.

Wednesday, January 30, 2002

*  Recent Topics

*  Fog Creek Home