Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

What am I doing wrong with Templates?

I am fairly new to this but have done simple website in other editors.

I like very much the concept behind CityDesk; but after going through the tutorial I still have some problems. They must be simple to resolve.

I want to change the default template colors that appear in the index.html. When I did that in an external web editor (Namo Web Editor 5) CD did not work properly.

I also tried to develop a different template in the Templates different from simple. I copied simple; went to Namo Web Editor 5; edited it (just putting a background -non-white- colour. CD did not work.

What is the correct procedure?


A E Senior
Sunday, January 13, 2002

It sounds like you're following the right procedure. I'm not sure what you mean by "CityDesk did not work" in these cases. Is CityDesk just not running at all, or is it doing something different than what you expected? In what way?


Joel Spolsky
Sunday, January 13, 2002

It is not doing what I expect. For example after changing a template it add a family of templates. Then when I preview the index.html page shows the following source code

<html><head><title>Site Index</title></head><body bgcolor="white"><p>CityDesk published the following variations of this site in subdirectories:</p><p><a href="aes_variations/index.html">\aes_variations</a><br>
<a href="HTML/index.html">\HTML</a><br>
</p><p>Click on any link to view it.</p></body></html>

and places it in the following directory:

if I go to the "\aes_variations" link I can see the three articles with the blue background. However when I click on the "return link"called HOME (italized), I get the Microsoft "The page cannot be displayed"announcement under C:\WINDOWS\TEMP\CITYDESK_-969519\aes_variations\WINDOWS\TEMP\index.html

I have tried to set up manually a link for HOME back to index.html and it still does not work.

Thanks for your help!

A E Senior
Sunday, January 13, 2002

Please note that I downloaded the free version and then I installed the Home version without deleting the free version first....could this be a problem??

A E Senior
Sunday, January 13, 2002

Aha. Here's what I think happened -- you added a FAMILY of templates when you actually meant to add just a template. In the templates window you probably have

-- Simple
-- Simple

when you meant to have

-- Simple
-- aes_variations

(Chances are, you didn't mean to make a new family of templates -- that's just an advanced way to get two entire versions of your site published using different templates for each version. It's intended, for example, for people who want to have an entirely different version of their site for small screen devices like Palms, etc.)

Now when you publish you are getting both template families, and CityDesk is making a subdirectory and publishing to both of them.

The solution: in the template window, select aes_variations and delete it, then add your new template (not a template family).

Joel Spolsky
Sunday, January 13, 2002

*  Recent Topics

*  Fog Creek Home