Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Lost ppt files

I am building a city desk site that includes a number of powerpoint files. I have noticed that on a number of occasions the updates I make to the ppt files do not seem to make back into the .cty file. The following seems to pretty consistently miss the update.

1. open citydesk
2. double click one of the .ppt files in the site
3. after powerpoint opens edit the file. For example change one word on one slide
4. close file in powerpoint, but do not close powerpoint
5. return to citydesk
6. file/compact site.
7. double click the .ppt file in citydesk
8. In powerpoint look at slide. note that change is not there.

There are other sequences that can produce this result, but this one I found seems to *almost* always loose the changes.

I looked for this sequence because it seemed citydesk was loosing the updates, but I could not be sure. Sometimes when you are editing files you think put in something and saved it, but you didn't :-).

Dan Sullivan
Monday, January 7, 2002

I'll look into it.

Joel Spolsky
Monday, January 7, 2002

Also, if you have a file and a template, and publish the file, and then set the template to None,  (why doesn't that prevent the template from being published at all? Nevermind . . .) it will still be published with its previous template.

R. C.
Wednesday, January 9, 2002


I have a bunch of articles that I just use to hold some links that are displayed by a script on another page.  There aren't actually any links to the articles.  So to cut down on their file size I set the template to "none" and re-published.  Worked fine.  Maybe you didn't save before you published again.

It might be nice to specify "use this article in scripts but don't publish it" but that might cause more problems than it solves.

The "never publish after" feature seems the best way to stop an article from being published at all.

Wednesday, January 9, 2002


I can't reproduce the problem you're seeing. Here's what I did:

* create a new CityDesk Site
* publish
* look at the article - it uses the template
* change the template to none
* publish again
* look at the article - it uses no template

Is there anything else it takes to repro this problem?

Joel Spolsky
Wednesday, January 9, 2002

Have you been able to duplicate the lost .ppt problem?

I now have a .ppt file change that I can't get to "take". I haven't even been able to find a keystroke intensive workaround. It has turned into a show-stopper as far as using CityDesk to manage the .ppt files for now.

Here is the sequence.
Initial state neither PP or CityDesk running.

1. Start CityDesk
2. double click patterns.ppt in CityDesk( the .ppt file in the site)
3. wait for PP to start.
4. Observer that PP has open a FOG....ppt file. In PP apply a different design template to slides.
5. observe that design template worked.
6. close .ppt file.
7 close PP.
8. double click patterns.ppt in CityDesk again.
9. wait for PP to start.
10. observe that new design template is still there.
11. close PP.
12. close CityDesk.
13. open CityDesk.
14. double click patterns.ppt in CityDesk.
15. observe that the slides have reverted to previous design template.

I have also tried this sequence with other sorts of changes to the .ppt file, like changing a word in a slide, and gotten the same results.

I have tried a number of other sequences too. I would be happy with a "click this, type that, then close and open CityDesk" sort of work around for now. However at this point I don't seem to be able to get the changes to this .ppt file to "stick".

Dan Sullivan
Wednesday, January 9, 2002

A couple of things...

1. What OS are you using?
2. What version of powerpoint?
3. Type 'set temp' at a cmd prompt and tell us what it says.

Also please try this..
Insert any old file and attempt to edit it with an external editor (any non-powerpoint file).  Does the problem also persist there, or only with powerpoint files?

Thanks for your help. Sorry to burden you with all of this, but we can't reproduce the problem here.

Michael H. Pryor
Wednesday, January 9, 2002

Dell Latitude C600

System Information report written at: 01/09/2002 06:33:58 PM
[System Summary]

Item    Value
OS Name    Microsoft Windows 2000 Professional
Version    5.0.2195 Service Pack 2 Build 2195
OS Manufacturer    Microsoft Corporation
System Name    PALOMAR5
System Manufacturer    Dell Computer Corporation
System Model    Latitude C600                 
System Type    X86-based PC
Processor    x86 Family 6 Model 8 Stepping 3 GenuineIntel ~4 Mhz
BIOS Version    Phoenix ROM BIOS PLUS Version 1.10 A03
Windows Directory    C:\WINNT
System Directory    C:\WINNT\System32
Boot Device    \Device\Harddisk0\Partition1
Locale    United States
User Name    PALOMAR5\Dan
Time Zone    Eastern Standard Time
Total Physical Memory    523,744 KB
Available Physical Memory    140,004 KB
Total Virtual Memory    1,800,620 KB
Available Virtual Memory    1,091,560 KB
Page File Space    1,276,876 KB
Page File    C:\pagefile.sys

set temp

Microsoft Windows 2000 [Version 5.00.2195]

PowerPoint 2000 SR-1 (9.0.3821)

I just opened a .xml file on the site. I right clicked the file in CityDesk did open with komodo. I noted that it had the Made a change, saved the file and closed it, but did not close komodo. Closed CityDesk, then opened it. Then opened the .xml file and saw that the change was still there. So it did work.

I have been editing about 5 different .ppt files on the site for the last week or so. Changes to these work *almost* all the time. When the change does not stick, usually the opening the file again and redoing the edits will clears things up. So the problem is quite intermittent. Lately though I have not been able to get the changes to take at all.

I also have a few XML/XSLT files on the site. I have been editing them with emac's, komodo and Occasionally these files pick up some trash at the end of the file. I assume this is the same problem that some other people have seen with HTML files.

I also have a Word file on the site which has been no problem, but it has not be edited as often as the .ppt's or XML files.

I also checked the W2k event log, in case there was a clue there. But the latest entries there are from 2 days ago.

Dan Sullivan
Wednesday, January 9, 2002

*  Recent Topics

*  Fog Creek Home