Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

CityDesk keeps publishing unchanged files

I added a new publish location to:

I've finally promoted the site and deleted the old site.  At any rate CityDesk is republishing the whole site (82 files)  every time I've published tonight.

I've compacted the site.  Made sure the "publish changed files" is checked. Closed and opened CityDesk at least 10 times.  I've deleted the citydesk.xml file.  I've rebooted twice.  Run out of memory once.  I've published about 6 times.

Just now, I edited but didn't change one article.  I clicked the publish button in the article editor: CityDesk started publishing my index.html file, my graphics files, the whole site all over again.  Before that I published the whole site.  Then without making a change or editing a file, I published again - CityDesk published all 82 files all over

What am I doing wrong?

Saturday, January 5, 2002

The main reason I can think of that this might happen is if for some reason CityDesk was unable to download the citydesk.xml file from the server. If that happened it would have no idea which files were up there and it would have to republish everything.

Another possibility I can think of is that you published using the dialog box (rather than clicking on the toolbar), and you checked "publish all files". After that when you publish using the toolbar it tried to publish all files again. But restarting CityDesk should have cleared this up. Michael, any ideas?

Joel Spolsky
Sunday, January 6, 2002

I've got three publish locations for the site so I always see the publish location selector dialog box.  The "Publish changed files" box is checked (not the "Publish all files" box).

The other two publish locations seemed to have worked fine.  The only thing different in the new "publish location" is that the "Subdirectory" field is blank.  The others published in a subdirectory. is the hosting service.

Among the very first things I see in the FTP progress dialog box is "no such file" twice. It scrolls by too fast for me to see exactly what is going on.  I presume it can't find the "citydesk.xml" file but it's there:

Sunday, January 6, 2002

Try ftp'ing from the command prompt.

Type 'ftp <insert ftp server here>'
Then login with username and password.
Then type 'get citydesk.xml'

And let me know what happens.

Michael H. Pryor
Sunday, January 6, 2002

I'm so confused but here is more information.

I used CuteFTP to see the difference between publishing to a domain in verses publishing to a domain in

Using CuteFTP and look at my web's files on the host:
For the Dreamhost site and looking at the direcory bar in the right-hand window I see my domain "/"  The CuteFTP "Default remote directory" for this site is ""

When I do the same in Yahoo, I see "/documents" even though in CuteFTP the "Default remote directory" is blank.

So, CityDesk seems to be publishing my site in the yahoo "/documents" directory even though the default directory is blank.

That is, CityDisk is publishing in the right place but maybe it's trying to retrieve the "citydesk.xml" from the wrong place.

I tried seting the the CityDesk publish location default directory to "documents"  of course City published in the Yahoo directory in /documents/documents.

Sunday, January 6, 2002

What happens if you set your subdir to /

Michael H. Pryor
Sunday, January 6, 2002

After changing the publish directory to /

Got this is the FTP progress window:

"550 Could not open: No such file or directory"

Then got an FTP error box:

"Couldn't put file: The server returned extended information"

Sunday, January 6, 2002

Oops.  I figured out whats going on...
It's a bug.  It will only happen under the following conditions:

1. Your subdir field is blank for the publish location.
2. The ftp server that you connect to does not set / to the directory that you are in when you log in.
3. Then when it tries to download citydesk.xml it tries to retrieve it as "/citydesk.xml", which is incorrect.

The workaround is to figure out what your actual ftp home directory is and put that as your subdir.  So for TK, the solution is probably to put "/documents" as the subdir.

You can find the correct subdir by using ftp from the command line and loggin in, then typing 'pwd'.  It will tell you the current directory.

Michael H. Pryor
Sunday, January 6, 2002

I logged in to ftp and got
230 Restricted user logged in.
(nothing that indicates the directory)

But: Eurica!

I tried the subdirectory "/documents" and realized it should be "/Documents" (capital D).

I hit the publish botton, CityDesk seems to have found the "citydesk.xml" and publihed nothing - just as it was supposed to.

Then just to make sure, I changed an article and published.  CityDesk did exactly what it was supposed to: published that one file.


Now I'm not quite sure what happened and how this post might help someone else publishing to a hosted site or similar hosts.

Sunday, January 6, 2002

*  Recent Topics

*  Fog Creek Home