Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Installation Problems


I got the following error message on my NT4SP6 box at work during the installation process:


Unable to register the DLL/OCX: DllRegisterServer export not found

Click Retry ...

I've tried installing as a normal (Super) user and Administrator.... but with the same error.

I've ignored it, but am experiencing some problems with the software.

I'll try it on my Win2K box at home this evening.

Peter Elliot.
Monday, October 15, 2001

It looks like we have all kinds of strange problems on NT 4.0.

I've been configuration-testing on Win 98, Win 2000, and Win XP, but it looks like NT 4.0 needs some more work.

Joel Spolsky
Monday, October 15, 2001

Upon opening CityDesk for the first time I clicked on "Learn how to use city desk" and maxized the help screen.  I went back to the orginal "welcome to city desk" screen (with the 4 buttons: "Create a new, ....) clicked on the "x" to close that window and got a:
"This program has performed an illegal operation and will be shut down" dialog box.

(not a big deal)

Terry Kearns
Monday, October 15, 2001

Yep, I can repro that one... should be easy to fix

Joel Spolsky
Tuesday, October 16, 2001

I just installed at home on Win 2000, IE 5.5 and when I double clicked on an HTML file in the CD main window, the Microsoft Office 2000 installer fired up and installed something, I'm not sure what, and then finally brought up the CD HTML editor window.

Just wondering if that is to be expected.


Rod Kratochwill
Tuesday, October 16, 2001

bwa ha ha!

Microsoft office is insane :)

I wouldn't worry about it unless it happens again. (Did they tell you what they were installing?)

Ever since Office got it's ultra-clever Install On Demand technology, whenever I install office, I install EVERYTHING, even the dumb stuff I'm never going to use, because it's better than running the risk of needing to find the dang Office CD when I'm trying to get something done.

Joel Spolsky
Tuesday, October 16, 2001

No it didn't say what it was installing, or if it did I didn't see it.  It only did it the first time and hasn't happened again.  I still have one machine, Win98 with Office 2000 that I haven't  installed CityDesk on.  I may try to do the install on that machine and see if I can figure out what it is installing, perhaps by not giving it the CD and see if it will tell me what it couldn't install.


Rod Kratochwill
Wednesday, October 17, 2001

I also got the office 2000 installer whilst installing citydesk - except it sort of hung (the office installer) and so I quit the office installer and city desk finished up its install with no quibbles.
I should say that I don't actually have the office 2000 installer CD - office PC (MIS dept. special!!).
However, the office installer kicked in again when I tried to launch citydesk AND so i quit again...and so the office installer kicks in again when I double-click "index.html" in the city desk window....totally repeatable on every launch of city desk.
machine - windows 2000 service pack 2, I have a screen grab of the processes running if this at all helpful..
the pop-up reads windows installer - then changes to office installer which reads: "please wait etc...configures office 2000 SR-1 professional"

guy dickinson
Thursday, October 18, 2001

*  Recent Topics

*  Fog Creek Home