Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Beta Confused

I can't edit articles on the beta.  When I try I get 5 or so error messages refering to the article editor - on which I duly clicked the send to Fog Creek button.  I also can't edit variables.  Or templates.  I may have confused things by installing and uninstalling.
Heres the sequence. I think...
I downloaded and installed the home edition upgrade.  Worked on my site for a while then discovered I couldn't edit variables.  Uninstalled 2.0.5 and reinstalled version 1.  Installed 2.0.5 into  seperate directory.  - Couldn't edit either variables or articles.  Uninstalled both versions and reinstalled 2.05 still no luck. 

Ken McKinney
Thursday, June 12, 2003

Sounds like some of the DLL and OCX files in your CityDesk directory are not registered.

The Setup program is supposed to take care of this, but for some reason it hasn't in your case.

The only way to fix it would be to run a command prompt, switch to the CityDesk directory, and they type

regsvr32 XXX

for each .OCX and .DLL file in the directory. For example

regsvr32 fcssubtmr.dll


I should re-emphasize that we consider this to be something that the SETUP program should have done for you and we consider it a bug that the SETUP program did not do this.

Joel Spolsky
Friday, June 13, 2003

Thanks - re-registering the dll's and ocx's seems to have solved the problem.

Ken McKinney
Friday, June 13, 2003

*  Recent Topics

*  Fog Creek Home