Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Cannot Install/Run CityDesk

I've downloaded CD three times and installed it on two separate W2K machines. In each case it has crashed with the same can't-get-out-of-a-loop error when I attempt to open the GETTING STARTED file. 

I've tried it with Norton Anti  Virus turned off.
I've rebooted
I've tried the steps recommended in
I've tried it on two separate machines as noted above.

Hardware - Dell XPS1000 and Dell GXS
Software - W2K SP2
IE 6.0.26

Possible reason - does this make sense?
Default Browser is Mozilla 1.2.1 - not IE (can I not use CD with Mozilla?)

Any help would be appreciated

Jim Mitchell
Wednesday, March 12, 2003

Ehh "the GETTING STARTED file", what is that?

So you cant start CityDesk?
Or cant you create a new site?

Or cant you even install it?

Wednesday, March 12, 2003

From CD's "System Requirements"

"Microsoft Internet Explorer 5.01 or later must be installed. We highly recommend Internet Explorer 5.5 or later. It does not need to be the default browser."

Wednesday, March 12, 2003

Did you installed it whilst logged on as an Administrator?

John Topley
Wednesday, March 12, 2003


I haven't had any of these problems on my Windows 2000 installs.  Differences: 1) I am running Internet Explorer 6.02 Service pack 1, 2) My user has admin privledges (I don't know if that is required, but I have not tried the install using a non-admin account.

It sounds like CityDesk installed without error messages but you get an error message trying to open the "Getting Started" article--yes?

I have had CityDesk "hang" on me where I had to kill it using Task Manager.  Someone from CityDesk suggested I reinstall Windows Scripting.  I downloaded Windows Scripting 6.2 from, installed it and it resolved my problem. 

Every once and a while I install some Windows shareware product that overwrites something CityDesk needs, but I reinstall CityDesk and that corrects the problem.

That about sums up what I don't know about your problem.

David Burch
Wednesday, March 12, 2003

Thanks to folks.

Yes I'm logged on as administrator.
Yes, I have IE 6.0.26 installed

I installed it each time with apparently no problems.
The problem comes when I create a new site and attempt to open the file "getting started" that's created with the new site.

I'll try reinstalling the scripting if someone else doesn't have an easier suggestion.

James Mitchell
Wednesday, March 12, 2003

Wasn't there some sort of problem with Access if you'd ever enabled security or something? Maybe that's what's preventing you from opening the demo site.

Darren Collins
Thursday, March 13, 2003

This thread is a perfect example of what's annoying me most about Fog Creek policy. Someone from Fog Creek (if there is more than one) could, and should, end this matter with a helpful explanation if they cared about their users at all.

Jorgen Brenting
Thursday, March 13, 2003

Try e-mailing them directly.
Thursday, March 13, 2003

Check that you have Microsoft Scripting installed... CityDesk may be looking for vbscript.dll and not finding it. It's a free download from

Somebody from Fog Creek
Thursday, March 13, 2003


Jorgen Brenting
Thursday, March 13, 2003

Yes.  Installing the scripting solved the problem. 

I haven't the slightest idea why it wasn't there (corrupted?), but now CD works fine.

Thanks nice person at CD

James Mitchell
Thursday, March 13, 2003


vbscript.dll is a standard part of Internet Explorer and thus every version of Windows, so it doesn't come with CityDesk, but for some insane reason there are computers out there that don't have it. We're going to start shipping it with CityDesk to eliminate this problem.

Joel Spolsky
Friday, March 14, 2003

*  Recent Topics

*  Fog Creek Home