Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

FTP Upload fail on overwrite


1. I can successfully publish if the destination directory is empty, so Citydesk doesnt need to overwite any files.

2. When trying to publish after that I get a number of error messages like: "FTP Error Uploading /newzealand02/index.html -- Couldn't put file: The server returned extended information". One for each file it tries to overwrite.

3. If I use a ftp-client and removes the files first, the publish goes well. All using the same credentials when connecting to the ftp-server.

4. Ive used a sniffer to see what happens, and after Citydesk sends the STOR-command, the server repsponds with a  "Overwrite permission denied" message. Altho my ftp-klient can overwite the file without any problems. Havent checked what command it uses tho.

Does anyone know how to get around this?

I bought CityDesk yesterday, to bring it on a trip, but I cant use it like this. Too much manual work.

Fredrik Jacobsson
Friday, December 6, 2002

Ummmif I use windows builtin commandline ftp, and navigates to the \newzealand02 directory, I can successfully upload (overwrite) index.html. The command the ftp-client sends is a "STOR index.html". No problem at all. Only trouble when Citydesk tries :/

Fredrik Jacobsson
Friday, December 6, 2002

You should contact your ftp service provider and see if they have any ideas.

CityDesk uses the EXACT same code that internet explorer uses.  So if you type in IE and try to overwrite your files that way, it is calling the same exact code.

Michael H. Pryor
Friday, December 6, 2002

How do I upload using IE?

Never tried that....

Fredrik Jacobsson
Friday, December 6, 2002

Ahh sorry, I needed to enable "ftp folder view" in IE's settings, without that I didnt have the option.

I successfully overwritten the file using drag and drop.

Thanks for trying to help tho.

Fredrik Jacobsson
Friday, December 6, 2002

Using a sniffer, I could notice these differences in the command-handling comparing an upload with Citydesk compared to Internet Explorer:

client: CWD /newzealand02/
server: 250 CWD command successful
client: TYPE I
server: 200 Type set to I
client: PASV
server: 227 Entering Passive Mode .......(cut)
client: STOR index.html
server: 150 Opening BINARY mode data con.....(cut)
server: 226 Transfer complete

Citydesk: (after trying to create the directories)
client: TYPE I
server: Type set to I
client: PASV
server: 227 Entering Passive Mode .......(cut)
client: STOR /newzealand02/index.html
server: 550 /newzealand02/index.html: Overwrite permission denied

The only difference beeing that Citydesk tries to put the file with the full path. Not knowing what the RFC says, Im not sure where the problem is. Altho Ive used approximatly 5 different ftp-clients total that have worked fine.

Fredrik Jacobsson
Friday, December 6, 2002


I managed to reproduce the error using the command-line ftp builtin in windows. Altho the sniffer shows no difference. So it's definatly a server-side error.

Ive contacted the ftp service provider.

Thanks for reading this far down the tread  :)

Fredrik Jacobsson
Friday, December 6, 2002

it was a bug with the proftpd ftp-server that my ftp service provider uses. after the upgraded to the latest release everything works smoothly. just fyi.

Monday, December 9, 2002

*  Recent Topics

*  Fog Creek Home