Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Richtx32.ocx is not registered correctly

Dear Folks,

    I install the lastest version of the CityDesk free edition in a Windows 98 in German, and when I try to open a document with the CityDesk I got the follwoing message:

Problem: "Richtx32.ocx is not registered correctly."

Solution: Search for Richtx32.ocx on your system.  Right click on the file and choose properties.  Select the Version tab.  We distribute version of the richtx32.ocx but it is only installed if you have a lower version number.  Sometimes you need to reboot after installation in order for this to take effect.  Make sure that this file's version number is at least or CityDesk may not be able to run.  If the installer is not replacing this file, reboot your computer in DOS mode and rename richtx32.ocx to richtx32.old.  Then reboot normally and run the CityDesk installer.

      I tried all the possible described solutions but the error  still there. Does anyone have a tip of how can I correct this problem?

      Best regards,


Celio Costa
Monday, August 19, 2002

You could always try 'regsvr32 richtx.32.ocx' (without the quotes) from the command line in the place where the ocx file lives. This will actually register the file with the OS. When you run this command you'll get a message box telling you that it's been a success or giving you a failure code.

Good luck.

John C
Tuesday, August 20, 2002

When you downloaded CityDesk, did you install the CityDesk "upgrade" instead of the full edition?

Joel Spolsky
Tuesday, August 20, 2002

Sorry folks,

      I have already did the COM registration (regsvr32) and the version I installed was the full one, not the upgrade.
      Does anyone has another idea?



Celio Costa
Tuesday, August 20, 2002

Reinstalling Internet Explorer might help..

cd user
Tuesday, August 20, 2002

I have reinstalled the IE6 but I still get the same error. I also tried to clean up the registry entries of the richtx32.ocx and reinstall the CityDesk but the error is still there. Maybe there is a type of imcompatibility with this version of the component and my Windows 98 in German.
It is said because I was eager to try the software.

Celio Costa
Tuesday, August 20, 2002

*  Recent Topics

*  Fog Creek Home