Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

FTP problems

Setting up 1st web site, with one simple page to start with.

Initially in my settings I had 'Web' as subdirectory. Hosting company said that was the wrong thing to do as they auto route ftp to a 'web' subdirectory. They cleaned up the mess, and all looked well.

Now leave subdirectory blank, and can't update my single page.

Get '550 index.html: Permission denied'
Then a dialog box with 'Couldn't put file: The server returned extended information'.

The Hosting company's response is: ' I guess it could be the FTP software you are using that is having problems...use WS FTP'.

Looked at other topics on discussion board, tried turning passive mode on/off, etc to no avail.

HELP!... as I'm really enjoying using CD


Greg Russell
Thursday, July 4, 2002

you can use similar settings in Citydesk as in WS_FTP.
That is:
- username
- password
and Path. My suggestion: enter the complete path from the root (e.g. /usr/home/ etc.)

If your directory setting is not ok, then Citydesk will attempt to publish to a directory in which it has no access.

It is a good idea to check out if no garbage (or citydesk.xml) is left of your previous attemt.
You can check this using a program like WS_FTP, or just the internet explorer.

Try :

Alternative (if you don't have a path): open command prompt en type
FTP ftpserver +<enter>
it will prompt for username/password.
The pwd command will show the directory where your provider leads you.

where you fill in the username/password/server url and path you know. See where it leads you.

Adriaan van den Brand
Thursday, July 4, 2002


Many thanks for your reply. Your advice worked.

I ended up deleting the index.html file, and then uploaded the page using CD. Problems disappeared.

I've also learned a little about ftp in a hurry.

Again, many thanks

Greg Russell
Thursday, July 4, 2002

*  Recent Topics

*  Fog Creek Home