Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

CityDesk 2 Trouble


when I start CityDesk it get the following error message:
Runtimeerror '372'
The control 'PinStripe' couldn't be loaded from  . Your version is propbably out of date. Assure that you use the control version supplied with your application.
(Translated from German)
The applicaiton quits after pressing OK. I guess it has something to do with Office 2003 I installed previously, but just a guess. I tried to figure out which ActiveX Library is in charge of PinStripe, but didn't find it.
So help is welcome.

Michael Bruckmeier
Sunday, December 14, 2003

PinStripe is a part of CityDesk and it is compiled into the CityDesk executable.

You almost certainly just have to reinstall from scratch.

Joel Spolsky
Tuesday, December 16, 2003

So I did. Control Panel > Sofware, removed CityDesk, downloaded most current Version and installed again. On startup, the message appears again und behaviour is as reported.
I also updated my virus scanner software and checked the installerfile and the my \Program Files\CityDesk Folder. No viruses reported.
CityDesk worked fine 15 days ago or so. But it semms to me that I've installed or removed software which this problem arises from. Unfortunatelly I can't say which program I changed.
How can I help you to help me ?

Michael Bruckmeier
Wednesday, December 17, 2003

I apologize that you are having so much trouble, this is quite unusual -- I think it denotes some part of Windows that CityDesk depends on which is not found.

If you are willing to run REGEDIT, you can make a small change:

* Look for
      Fog Creek Software
* On the right hand side, click on "VerifyAllRuntimeComponents"
* Choose Edit | Delete

Now when CityDesk runs it should check that everything it needs is installed in the correct place. This will, hopefully, give you a more accurate error message about exactly what file you are missing.

Joel Spolsky
Thursday, December 18, 2003


I removed the entry as you said. And like magic, from this time on CityDesk works out very fine, as I know it.

A big thank you !

Michael Bruckmeier
Monday, December 22, 2003

I updated from Office 2000 to Office 2003, which installs Microsoft Access 2003.

When I am lunch CityDesk the following error appears.

"The control element (DLL) Pinstripe can not be loaded. The current version is possibly not up-to-date. Please make sure, that you work with control element which was delivered with the application."

A reinstallation of CityDesk does not fix the PinStripe error.

Delete of the registry entry does not fix the problem.

Thursday, February 12, 2004

*  Recent Topics

*  Fog Creek Home