Fog Creek Software
Discussion Board

Knowledge Base
Terry's Tips
Darren's Tips

Images do not show in Preview Mode

Following the simple instructions, and exactly as shown in the example video, I drag a small .jpg file from my Windows desktop into a page I am editing with CityDesk.  It looks fine.  I set the picture to either appear with text wrapping or inline and then save and close the page.

When I hit preview and attempt to view the updated site with Internet Explorer or Opera, that page has a placeholder where the image should appear.  The only image I can see is the "Made with CityDesk" button.

Experimenting a little, I try to paste the "Made with CityDesk" .gif file on another page using the insert picture function and selecting that .gif file from the pull-down list.  Again, all I get is a place holder for the image when previewing in the browser.  Experimenting further, I try inserting images in the default simple template.  Again, just a place holder appears when previewed.

This seems pretty odd for software that is designed for simplicity.  It looks fine when I am editing the site, but when I attempt to preview the site it is missing any pictures I have added.  Something is broken, but I can't find anything wrong.  Help me please!

Dave McGraw
Sunday, November 2, 2003

I decided to open the simple template again and edit the "Made with CityDesk" graphic.  Unfortunately, I now cant even get that one to work.  When I preview, all I see is a placeholder.  I tried to select the exact same graphic, but when I do the preview looks as if Internet Explorer has a reference to an image that does not exist.

When it worked correctly, I could look at the properties of the image as viewed by Internet Explorer and the address of the picture it was displaying was:


Now that I've tried to update the picture (with the same picture), Internet explorer is looking fo a picture at:


I don't know if this helps, but I am completely stumped.

Dave McGraw
Sunday, November 2, 2003

Never worked for me either but I didn't watch the video.

You've got to drag the image into the CityDesk main window (the one that shows all the files), then do an "Insert Picture." That works every time.

Sunday, November 2, 2003

Nope...tried that.  I am sittting in an internet cafe, "The Digital Cup", where I have just installed CityDesk on a Windows XP machine, and it works perfectly for drag & drop AND preview/publish -- however I do it.  The problem only seems to exist on my home machine where I am running Windows 2000 Professional.

Is anyone else running Win2K that sees this problem?  According to the system requirements, it should work fine on Win2K.  Darn!  I've already written some content and can't continue until this is fixed.  :-(

Dave McGraw
Sunday, November 2, 2003

Here is what I do. Where ever the image is I right click and "save as." Then drag the file into CityDesk from where  you saved it. Then "insert picture" in CityDesk.

Sunday, November 2, 2003

I do the same thing as tk, I am using W2k ad I don't have that problem. I also first drag the image to the CD main window.

Ron Lane
Sunday, November 2, 2003

OK, I have figured out what the problem is, but I have no clue as to how to fix it.  When Citydesk generates the html, it has a link to a file called m_dave_office.jpg.  The actual file that I find buried deep into the directory tree is:

If I manually edit the generated HTML to reference the strange file name everything looks OK again.  What is going on!  I've tried everything exactly as you all have suggested -- and I've tried other things, but the generated html always refers to a valid directory with an invalid file name!

No method of pasting, copying, or inserting the pictures makes any difference.  I've invested a lot of time and still can't get any images to appear in my published or previewed document.

Dave McGraw
Monday, November 3, 2003

After studying the "magic name" postings in this discussion area, I now know that the problem is that my html is being generated with a normal name and not the bizarre magic name.  Why I should have to manually copy my images to a temporary location deep in the directory tree is beyond me, and makes this program far too clumsy to use.

I have to catch a plane in a few hours and am pretty frustrated that I blew a weekend and lost sleep trying to get a picture into a web page.  I tried every technique suggested and every other technique humanly imaginable.  I downloaded and installed twice.  The software simply does not work as advertised.  All of my other applications perform normally, so I do not feel it is any problem with my system.

Dave McGraw
Monday, November 3, 2003

Dave McGraw :re not the bizarre magic name

1stly magic names used by CD are not bizarre ...

Did you know that when you move an existing file within CD [from one folder into another folder] that magic name retains its identity.. for me a very useful feature.

What I wish that Fog Creek would do however is allow magic names to be used in {$ include "magicname" $}

2ndly when using magic names the way that CD intended those links are never broken ... also a very nice feature.

What's not nice is that magic names cannot currently be seen the way they should be seen ...

David Mozer
Monday, November 3, 2003

To Dave,

Unfortunately I am not sure that many of us can help you with your problem.  I have used CD on a few different Windows platforms, and all worked as it should. 

You import the picture into CityDesk, so that you can see it in the tree structure, along with all the documents and html files.  I usually don't do the drag-n-drop method, but import from the menu.  In the document, you can insert the picture and select from the drop down list.  You never have to worry about the magic names (which is why I guess they are called "magic") and everything appears as it should. 

Even if you edit the templates with an external editor, CityDesk exports out all the files to disk so the editor will display everything for editing, including the css file (now THAT is handy).

To say that CD doesn't work as advertised isn't quite right.  It does work, and you said yourself it worked on another machine (XP).  Before you go any further, make sure you have the latest updates for W2k AND internet explorer.  Also, shut down any other programs running at the same time.  Sometimes programs from different vendors can conflict.  Anyway, these are just a few ideas.

hope this helps...

Jeff Kolker
Monday, November 3, 2003

Try Compacting the database, too. Sometimes when I see screwy behaviour, this helps.

Darren Collins
Sunday, November 9, 2003

*  Recent Topics

*  Fog Creek Home