Naming an interface, any ideas?
The answers to Sathyaish's question on naming were pretty good so I thought I'd ask one of my own. (apologies if it's covered in Patterns book somewhere)
If you have a collection of IOrderItem then I'd be persuaded to have a collection called IOrderItems of IOrderItem.
Not quite what I meant Simon, it's a name for the common interface between all four. Lots of the code can be reused across all four types, my problem is because an order and an invoice are for the most part very similar (they both have accounts and a list of items consisting of products and quanitities) but they are two different objects. I just object to having to write that my SalesInvoice class implements the IOrder interface and I'm looking for a more neutral word. (and Parent/Child isn't really specific enough)
Sorry transaction has already been taken.
Not bad Simon, it's a lot closer but it still could mean almost anything, on the other hand at least it doesn't tie us down too badly and I could probably reuse that name in a couple of other circumstances.
Fog Creek Home