Fog Creek Software
Discussion Board




Help for Newbie Trying to Connect to Win Workgroup

I have a Win2000 laptop from work which was is usually connected to a domain at work.  I took it home and wanted to connect it to my home workgroup, so I switched the network identification to a workgroup.  When I turned the machine off, and later attempted to log back in, it didn't accept my login/password.  What do I do?

anon
Tuesday, July 06, 2004

At the Ctrl-Alt-Delete log-in prompt ensure your network is pointing to workgroup instead of your corporate domain.

Get a software firewall and some virus protection too while you are at it, always a good thing.

Li-fan Chen
Tuesday, July 06, 2004

There's no textbox for domain.  If I type my username & password, it doesn't recognize me.  If I type WORKGROUP\username & password, it still doesn't recognize me.

anon
Tuesday, July 06, 2004

It sounds like you don't have a local account on the machine.
The domain textbox won't come up because you aren't a member of the domain.

If you don't have a local account, login as Administrator and create one.  Use the same password as on your regular domain account, it makes life simpler.

Simon Lucy
Tuesday, July 06, 2004

Thanks, Simon.  I tried to login as Administrator, but it didn't accept the empty string as the password.  I suppose the IT people at work set it.  Any other way to log back on?

anon
Tuesday, July 06, 2004

Is there an "options" button on the login-dialog? Click on it....

Jack
Tuesday, July 06, 2004

You can login to a machine in a domain without a domain controller, it will use your cached profile.  However you can't join a domain without it trying to find a domain controller, also I doubt you have the permissions to do the joining even so.

So, you're stymied.

Simon Lucy
Tuesday, July 06, 2004

sudo mount -t smbfs \
        -o username="hoser" \
        -o uid=hoser \
        -o gid=hoser \
        -o fmask=0666 \
        -o rw \
        -o workgroup=WORKGROUP \
        -o debug=4 \
        //MACHINE.NAME.COM/SHARE /mnt/MOUNT/PATH

Anything else you need to know?

hoser
Tuesday, July 06, 2004

> hoser

*lol*

Li-fan Chen
Tuesday, July 06, 2004

You shouldn't have made the change to workgroup. Just have the same name for your workgroup on the other machines as the domain name at work (i'm not even sure that's necessary).

I made the same mistake. You need to see your system administrator and get him to put you back on the domain. He will have administrator rights on the domain, which are necessary to add a machine to a domain.

Stephen Jones
Wednesday, July 07, 2004

*  Recent Topics

*  Fog Creek Home