Fog Creek Software
Discussion Board




.net Global Assembly Cache

OK, I tried to install a dll into the "Gac" - but it appears to be the wrong version.  I now try to uninstall it and gacutil gives a really helpful message:

Unable to uninstall: assembly is required by one or more applications

Any idea on how to find out what application is requiring the assembly?

Ken Ray
Thursday, June 24, 2004

http://blogs.msdn.com/alanshi/archive/2003/12/10/42690.aspx

Google.  Your friend.

//\
Thursday, June 24, 2004

Joel on Software Forums:

Also your friend.

Thanks, problem solved

Ken Ray
Thursday, June 24, 2004

http://www.despair.com/laziness.html

Greg Hurlman
Thursday, June 24, 2004

I also would like to note that a guy here is being let go in part because he can't google/search for answers on the web.  Am I serious?  Yep.  We get paid to come up with answers for clients.  If I have to hold this guy's hand everytime a this guy needs to install an assembly in the GAC, it's wasting valuable time.  Learn to find (or discover) the solutions yourself - you'll become more valuable in the process...

//\
Thursday, June 24, 2004

Apparently I need a grammar checker ;-)

//\
Thursday, June 24, 2004

Of course, while you denounce Ken Ray's apparent lack of either googling skills or motivation, you are also contributing to the problem as an enabler ;-)

Joe
Thursday, June 24, 2004

Strange as it seems, I know how to use Google, plus the forums on asp.net, and a variety of other places.

There are a many ways to get information on a certain topic.  The secret is to know what is the most efficient way to get reliable, accurate information.

Ken Ray
Thursday, June 24, 2004

*  Recent Topics

*  Fog Creek Home