Fog Creek Software
Discussion Board




Virtual PC / Redhat meltdown

Hey all --
I'm running VirtualPC on XP pro and have Redhat 9 installed.  Basic install works great: problem is the X server, which is turning into a real pain.  Oh, it runs, all right... it produces garbage.  I've been dorking with the XF86Config file for hours now.

My setup:
Host System - XP pro
Guest OS - Red Hat 9
Card - Nvidia Geforce 5200
Monitor - generic Dell POS @ 60hz

Anyone experience anything similar?  Changes in driver, resolution, bpp, don't seem to help any.  Basically I'd be happy to get X running at 800x600 @ 16bpp.  But even that seems to be eluding me.
thanks,

john haren (seriously considering Solaris)
Wednesday, June 23, 2004

cat /var/log/XFree86.0.log >dump

Send me the dump with a description of your problem.  No guarantees.

hoser
Wednesday, June 23, 2004

Thanks!

horace
Wednesday, June 23, 2004

Linux on VirtualPC? Not supported. Use VMware.

VMware
Wednesday, June 23, 2004

I remember having this problem and I found an article about it on the VPC site (pre-Microsoft takeover). I believe that you have to change the color bit-depth setting to 16 from 24 in the X config. Once you do that, everything should work fine.

Patrick Franz
Wednesday, June 23, 2004

And here is a link to the KB article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;825379

Patrick Franz
Wednesday, June 23, 2004

i had problems with the gnome desktop.
It eats up lots of resources, and apparently there are memory leaks
Dump it for anything, i use icewm. It might solve your problems.

Michael Moser
Thursday, June 24, 2004

I have the same setup running, but had the same problems as you when I installed. If  remember correctly it has to do with color depth. Check the Virtual PC help. Virtual PC does not support all color modes. Set your RedHat desktop to a supported setting and everything should be fine.
My settings are 800x600, 256 colors, S3 Trio64 (generic) 8Mb

Just me (Sir to you)
Thursday, June 24, 2004

Just to echo, I have Linux running on VPC. You must use an 8-bit, 16-bit, or 32-bit video mode; in particular, 15-bit and 24-bit will fail.

http://dotnetguy.techieswithcats.com/archives/004025.shtml

Brad Wilson (dotnetguy.techieswithcats.com)
Thursday, June 24, 2004

Thanks everyone!

I'm going to try changing only the bpp and work from there.

horace
Thursday, June 24, 2004

Ha ha!  16 bpp works!
(Talking to ya from inside Redhat9.)
The 800x600 resolution blows, though.  Gotta see what I can do about that.

Thanks to everyone for the help.

john haren
Thursday, June 24, 2004

Hi
I just managet to go 1024x768 16bps on VirtualPC using a gentoo.
I just selected S3 generic (not trio) with 8MB of RAM and all goes fine

David Lightman
Sunday, June 27, 2004

*  Recent Topics

*  Fog Creek Home