Fog Creek Software
Discussion Board




How to rearrange Windows Menu?

Hi Everybody,  Somehow, I have rearranged the menu in 'My Documents'. The main menu to open 'My Docs' is OK with Open(lead); Explore; Search; etc.  However, when I bring up any folders within 'My Docs' the menu begins with Search(lead); Open;  Explore; Refresh Thumbnail; etc.  If I simply left-click it brings up the search screen to 'find' something. When I right-click it brings up the menu with Search(as first choice) and I must highlight Open(second choice) to open the folder.    How do I make 'Open' the default(lead) within these document folders.  I  am on a Toshiba Laptop running Win X-P.  Thanks, Rae

Rae
Monday, June 07, 2004

Could you please be a liitle less clear?

Sigmund Fraud
Monday, June 07, 2004

Just stratify the hopsigator and reboot.

Mr. Science
Monday, June 07, 2004


With reference to the OP, I am guessing the forum has

(1) either been discovered by a troop of nincompoops in that posts of these kinds have genuine interest,

OR more seemingly

(2) Some guy or guys are deliberately making these kinds of posts to mock at the more inquisitive kinds on this forum.

Sathyaish Chakravarthy
Monday, June 07, 2004

OR most likely

(3) A bunch of poorly-educated "programmers" are now getting assigned their first outsourced projects and are running around trying to figure out what to do

Rob
Monday, June 07, 2004

Find is the default action for a file folder.

Open any explorer window -My Documents will do fine - and then go to Tools|folder ioptions|file types.

Scroll down to N/A for the extension and you will see two folder icons - one for file folder, and one for folder.

What you are dealing with here is file folder. Double click and you will see an advanced tab. You click on that and for the left click you can then add new actions instead of find/search and also specify the default action to be Open should you wish.

I would do that (and consider using a separate icon for file folders than for folders to distinguish between them), and then post back with any other queries. You can also change the order of the right click menu (which actually is the order in which the different actions appear in the registry) but it is more fiddly, and I doubt if you'll need to.

Have a nice day.

Stephen Jones
Monday, June 07, 2004


Even more likely,

Some sadistic, anti-outsourcing fanatics are doing it to create a false impression of that kind.

Sathyaish Chakravarthy
Monday, June 07, 2004

Stephen, I went into file types within folder options, however it won't let me add new actions or change existing.  Within advanced,  'Find' is the only action in the window.  The four choices to the right are New(which I can access); the other 3 are shaded with no access, Edit; Remove; Set Default.  When I bring up New, it gives me a New Action Screen with 2 fields.  However when I add 'Open' to the 1st field it says 'The specified program could not be found.  Make sure file name and path are correct.'  Same with 2nd field.  Is this how I change this?    I tried folder options; view, file types previously before my first post with no luck.  I notice that the other file types on the list have access to edit, remove, set default.  Only Folder and File Folder have these 3 choices shaded.  I am not a programmer.  When I do have an occasionally problem, you guys are quick to respond.  Thanks for all your help.  Rae

Rae
Monday, June 07, 2004

Rae, try calling Microsoft tech support... this is a developer's forum.

Everyone
Monday, June 07, 2004

RAE,

start regedit, go to HKEY_CLASSES_ROOT\Directory\Shell and remove the (Default) entry

Jack
Tuesday, June 08, 2004

To get things back to the default you go to they reg key Jack mentions and expand the shell folder; you will then see find, expand it and open the command key. Then change the command path to %SystemRoot%\Explorer.exe and things should go back to normal.

Incidentally if you want to add open as a command in folder options then you must browse to the explorer.exe program. You can't leave the text box blank or you will get the error message you referred to.

Stephen Jones
Tuesday, June 08, 2004

By the way, props to Stephen for actually being able to decipher the original post :)

Joe
Tuesday, June 08, 2004

I had the smae problem. I fixed it simply by going to the folder options, and in the general tab, click on 'Open each folder in the same window' or ''Open each folder in its own window', which ever is off.
Click Ok, and then do it once more to bring it back to what it was before.

It seems that Windows will reset it's action for folders to the default.

Oussama (OZ) Mubarak
Wednesday, June 23, 2004

*  Recent Topics

*  Fog Creek Home