Fog Creek Software
Discussion Board




Gawddamn Win XP Pro

I've noticed a downright irritating behaviour on my Windows XP Pro machine.
I tried to delete some files and, no matter what, windows keeps on saying that some process is using those files.
I tried to reboot, a clean shutdown and I'm about to sacrifice my neighbours virgin daughter to the gods.

What the hell is going on?!?

RP
Wednesday, May 12, 2004

Try removing them in Safe Mode.

Interesting thread on the topic at
http://weblogs.asp.net/oldnewthing/archive/2004/05/11/129759.aspx#FeedBack

KayJay
Wednesday, May 12, 2004

Try using procexp (sysinternals.com) to see which process is holding the file handle and then killing it.

ICBW
Wednesday, May 12, 2004

Hey, I've had this problem too.

Good to know it's not some weird virus/trojan I'm too lazy to chase down (I update my machine religiously).

Warren Henning
Wednesday, May 12, 2004

I'll bet you've got web view enabled.

I *think* it's the file preview that's "locking" the file. You click on the file to select it, the preview thingy loads the preview, then you hit delete, except the preview is locking the file.

Try selecting another file, then right-click on the file and select delete. Alternatively, turn off web view or nuke them through the command line.

Let me know if that doesn't help.

Philo

Philo
Wednesday, May 12, 2004

On my system it's sometimes explorer's fault -- at least for media files. It seems to me that I can't delete some files as long as explorer shows info about the file in the status bar ("Type: Audio Video File, Last Changed: etc").

Martin
Thursday, May 13, 2004

"I *think* it's the file preview that's "locking" the file. You click on the file to select it, the preview thingy loads the preview, then you hit delete, except the preview is locking the file."


gawds.  only on windows.

FullNameRequired
Thursday, May 13, 2004


I've had this problem with image and media files.  It IS the file preview crap.

I've always been able to drop into the command shell and delete the files the old fashioned way.  I'm too lazy to try to fix Explorer by tweaking its settings :-)

Craig
Thursday, May 13, 2004

*  Recent Topics

*  Fog Creek Home