Fog Creek Software
Discussion Board




Make it go away

I recently ran windows update, and now the "Windows Messenger" thing is always running.  When I try to "Exit" Windows Messenger, it refuses to quit saying:

"There are other applications currently using features provided by Windows Messenger.  You must close these other applications before you an exit ...  These other applications include Outlook, MSN Explorer and Internet Explorer."

From a dumb user's perspective (which I am), I'm not running _anything_.  The desktop is clear and I've just rebooted.  Task Manager shows 0 applications. 

I do have and explorer.exe process running, but wouldn't that be the desktop app itself?  So now, Windows Messenger is a required application?

"I can't close my eyes and make it go away..."

Bono.

hoser
Tuesday, May 11, 2004

Yeah, it's a pain in the rear.

The applications mentioned usually have a Messenger plugin, like Outlook can show a pane of online contacts, etc.

It can be disabled, and I've done it before.

Just google "disable windows messenger".

Capn' Kirk
Tuesday, May 11, 2004

Too bad it's not like the firewall in xp - off by default

send money
Tuesday, May 11, 2004

Download 'Shoot The Messenger' from www.grc.com.  Nice and simple an prevents you knackering your registry when you try to do it yourself.

Not Waving But Drowning
Tuesday, May 11, 2004

You need this:

http://www.grc.com/stm/shootthemessenger.htm

KillYourTV
Tuesday, May 11, 2004

er, the last two items have absolutely nothing to do with Windows Messenger.
and you don't need a tool or the registry to turn off the messenger service (what the gibson tool does) either. just go to the services manager and turn it off.

mb
Tuesday, May 11, 2004

It sounds like the original question was actually regarding the Windows Messenger IM program that comes with Windows XP (similar to MSN Messenger that you can download from Microsoft).  I discovered that you had to kill a process called msmsgs.exe and then delete the folder "C:\Program Files\Messenger" or else it starts up again in a few seconds.  I then proceeded to download the MSN Messenger program because it works better than the one that comes with Windows XP and doesn't give that message when I try to kill it-- "There are other applications that are currently using features blah blah blah".

dover
Tuesday, May 11, 2004

In Outlook, go to Tools > Options > Other and uncheck the box that says "Enable Instant Messaging in Microsoft Outlook"

Scot
Tuesday, May 11, 2004

Actually, its what dover and Scot said.  Thanks for the information.  I'll give it a shot tomorrow.  That Windows box used for VxWorks development.

hoser
Wednesday, May 12, 2004

I would'nt recommend deleting it from the disk, rather remove it via the "Add Remove Programs" option in the control panel, first by removing it from the "Change or Remove Programs" tab (if present) and then removing it from "Add/Remove Windows Components" - its the last option.  I generally remove MSN Explorer as well.

PaulT
Wednesday, May 12, 2004

Why are people telling the person to get rid of messenger altogether? That was never implied in the original posting.

Anyways, one of the key things that can force Messenger to stay open is Norton Anti-Virus.

I had the same problem, and I went into Norton Anti-Virus, clicked "options" and disabled "Instant Messager" scanning for Windows Messenger.

Now the problem has gone.

If you have Norton, try it.

meta4
Tuesday, May 25, 2004

meta4,
I found this thread on Google and wanted you to know that solved my problem. Thanks bro.

catapultic
Thursday, June 03, 2004

meta4, i just googled "there are other applications currently using features provided by windows messenger" and found this thread immediately.  I saw your post, and instantly I thought *thats it*.  Well it was, my problem is solved- now i don't have to open task manager and kill the process, thank you for the good post.

Joseph
Friday, June 04, 2004

Meta4 gave the precise solution! Good show!

Thanks

Ricardo Haughton
Friday, June 18, 2004

"In Outlook, go to Tools > Options > Other and uncheck the box that says "Enable Instant Messaging in Microsoft Outlook"

This worked perfect for me! Thank you.

eucasafari
Wednesday, June 23, 2004

From my experience, the problem is caused by one or both of two things- Norton antivirus and some other firewalls, seem to call part of messenger to load in the background. In task manager, it shows itself only under the processes tab. Right click messenger from the task bar and close, it won't close.

But there's another thing if memory serves- remember when XP first came out and tons of people were complaining about messenger spam? There's that same messenger component loaded to make that work. So, doing what mb said, "just go to the services manager and turn it off." works in that case too.

Robt

Rob Trujillo
Thursday, September 02, 2004

*  Recent Topics

*  Fog Creek Home