Fog Creek Software
Discussion Board




Best way to start with J2ME

I want to check what J2ME is and what can it be used for. What would be the best way to start? I would like to create a proof-of-concept application, which:

a) Loads some data from a server over HTTP (SOAP is OK).
b) Does some simple visualization of the loaded data with some numeric (or alphanumeric) input from the user.
c) Transmits data back to a server over HTTP (SOAP is OK).

Is J2ME good enough for that? If so, is there a tutorial, which would cover the above topics? I know the Java language, so what I need to learn are the APIs.
My preference would be to create prototype as soon as possible, imperfect it might be. I would also like to test it with a real phone. I am Verizon wireless customer and currently have LG VX6000 phone. How can I figure out whether the cell phone supports J2ME? And even if supports it; will it be feasible for me to load my own applications?
If my phone does not have J2ME or I cannot easily use it for testing, what emulation environment can I use?

http://www.alexlechuck.com
Monday, April 26, 2004

Unfortunately Verizon handsets (a) do not support J2ME and (b) wouldn't let you load your own code even if they did.  Many Sprint handsets will work, as will many flavors of GSM handsets (which you can then choose AT&T, Cingular, or T-Mobile as carrier).

The best option for getting started is working with the wireless toolkit from Sun http://java.sun.com/products/j2mewtoolkit/download-2_1.html

For tutorial type articles, checkout http://developers.sun.com/techtopics/mobility/

Tom
Monday, April 26, 2004

I understand that the JBuilder IDE from Borland can work with J2ME. There is a "free for personal use' version.

Yes, you can program only with the SDK and with a text editor. However, a proper IDE can make you a lot more productive and can make your learning curve gentler.

Maximus
Tuesday, April 27, 2004

There are at least two plugins for Eclipse that I am aware of that allow it to work with the J2ME wireless toolkit from Sun.

Look for them at:

http://eclipse-plugins.2y.net/

A.F.

Avrom Finkelstein
Tuesday, April 27, 2004

I looked up your model of phone "LG VX6000" and as far as I can tell, it does not support Java midlets.

My wife recently got a Motorola phone which supports it. (Using the Rogers/AT&T network here in Canada.)

A.F.

Avrom Finkelstein
Tuesday, April 27, 2004

Thank you for your suggestions. I will look at both the SDK and the eclipse plugin, since I am already using eclipse.

http://www.alexlechuck.com
Wednesday, April 28, 2004

*  Recent Topics

*  Fog Creek Home