Fog Creek Software
Discussion Board




Anyone using Eclipse 3.0 and CVS?

Hi,

I'm using Eclipse 3.0 M8 (an open source IDE for those who don't know it) on a Windows XP box, and have it set up to check out files from a CVS repository that lives on a Unix box.

But -  despite setting the appropriate preferences, every time I check out the project, the files are coming back with CVS keyword expansion turned on (e.g., with revsion numbers etc fully expanded).

This causes problems when we're merging things back in, and I'd like to get Eclipse to check out files with "keyword compression" (so you only see the tags in the editor). But it just doesn't do it. Is anyone else using keyword compression OK? Ie., could this be something to do with our combination of client and server, or is this just a bug in Eclipse?

Thanks for any ideas...

Dave the developer
Friday, April 23, 2004

Which Milestone build are you on?  M8?

Joe Blandy
Friday, April 23, 2004

Duh, sorry.  Read too quickly.

Joe Blandy
Friday, April 23, 2004

Hi. I'm using 3.0M8 but not using CVS. I'm finding lots of bugs in Eclipse 3.0 that weren't there in version 2.1.

Perhaps install 2.1 on a spare box and see if the problem persists. You could even install 2.1 on your own box (since uninstalling 3.0 would be as easy as renaming the folder - at least I really hope that's right).

RB
Monday, April 26, 2004

Mulitple Eclipse installs on one box work just fine.  Eclipse doesn't use the registry, but insteads writes configuration data to its local file store, so it's easy to try out new versions or run multiple configurations.

Ben Combee
Thursday, April 29, 2004

*  Recent Topics

*  Fog Creek Home