Fog Creek Software
Discussion Board




Odd IIS Problem

I am trying to configure a web server, and SSL works, but http does not; meaning http://blah.com does not work, but https://blah.com does.  Both ports are properly assigned, 80 and 443.  if i change the http port to somthing else, like 81 I get the same problem.  the Page that displays is a "You are not authorized to view this page"  What gives?

Christopher Hester
Wednesday, March 31, 2004

In the IIS config console, open the propeties for the web site, go to the "directory security" tab, and click on "edit..." in the "secure communications" box.  Make sure "Require secure channel" is not checked.

ken
Wednesday, March 31, 2004

What is the HTTP error code shown?

Greg Hurlman
Wednesday, March 31, 2004

You are not authorized to view this page

Christopher Hester
Wednesday, March 31, 2004

Ken I did that with no success.  Any other ideas?

Christopher Hester
Wednesday, March 31, 2004

Check the permissions of the directory that hosts the page you're trying to get to.

Wayne
Wednesday, March 31, 2004

Are you using client authentication on the SSL?

Just me (Sir to you)
Thursday, April 01, 2004

No, how can I check this?

Christopher Hester
Thursday, April 01, 2004

Check the IIS logs - should be in %winsysdir%\LogFiles\W3SVC1 or something to that effect.  You should see an entry your rejected request- it may yield a clue.

ken
Thursday, April 01, 2004

Same as in Ken's answer, but look at the "Client Certificates" box.

Just me (Sir to you)
Thursday, April 01, 2004

Ken, thanks your solution worked.  the first time i tried i left the 2nd box checked, which gets grayed out when the above is unchecked.  I went back and unchecked both.  thanks


Thursday, April 01, 2004

Glad I could help!

ken
Thursday, April 01, 2004

*  Recent Topics

*  Fog Creek Home