Fog Creek Software
Discussion Board




Any solution to decrease long load time?

Any solution to decrease the long load time while debugging using VS.NET2002? I am running my dll inside IE. When I try to debug, "the output" window in VS.NET IDE keeps showing lots of dll getting loaded from system32 dir. It takes about 4 minutes for all the dlls to finish loading.
I am using P4, 17Ghz, 1gb ram and WinXP.
Upgrading the system is not an option for me.

Sam
Friday, February 27, 2004

17Ghz!?!...  wow... where I can get one of those.

Almost Anonymous
Friday, February 27, 2004

I need a 17Ghz machine too ;-)


Friday, February 27, 2004

I meant 1.7Ghz

Sam
Friday, February 27, 2004

You need to check, it could actually be a 8088 machine.

Evgeny Gesin /Javadesk.com/
Friday, February 27, 2004

Are the dll load messages evenly spaced, or is there one of two dll's that cause long delays.

I know Internet Explorer isn't exactly fast to load but 4 minutes seems extravagant.

Try deleting all the breakpoints in your project and seeing if that makes a difference.  Visual Studio seems to sometimes reach a point where lots of break points cause everything to reduce to a crawl.

Also if IE fires up fast outside of the debugger then try doing that and attaching instead.

Rob Walker
Friday, February 27, 2004

I'm pretty sure there was an option in VC6 to stop VC trying to find debug info for all the DLLs the program loads. I can't find the VS.NET equivalent, but I'm sure it must be in there somewhere.

As another possibility, try downloading the Windows symbol files from MS' website. If your PC is spending ages finding them, or trying and failing to get them from a symbols server, that might stop that.

If none of those off-the-cuff ideas are of any use, I suggest you get someone else to upgrade the system for you :)

Insert half smiley here.
Friday, February 27, 2004

Thanx for all ur help...
I found a solution myself..changing the working directory solved the problem.. earlier it was pointing to a sub dir inside the system32 dir...when i pointed the working dir to c drive, it loads quickily..

Sam
Friday, February 27, 2004

Oh, change the working directory.  Yes, makes perfect sense why that would make the load time decrease.

And ESR rants about CUPS....

Should be working
Friday, February 27, 2004

*  Recent Topics

*  Fog Creek Home