Fog Creek Software
Discussion Board




Quick hardware / VS.Net question

I'm turning to the JoS crowd as a last resort.  I've looked everywhere else for answers to this.

Anyway, I'm running VS.Net 2003 on my PC.  Often when I leave it idle for long periods, open and close other applications, then switch back to it, it hangs.  It gets about half way through the redraw and just stops.  The CPU usage chart in task manager shows 99% with no other apps running other than services, Norton, and the other usual suspects.

My PC has 512MB RAM, so I figured maybe I'd bump it to 1024 (which is what I've seen recommended).  The problem is that I have a Dell Dimension 8200, and Dell sold 2 versions of it - one with a 400 MHz front side bus and one with a 533 MHz front side bus.  The 2 versions take different types of memory.

I've looked all through my system settings and can't find out what my FSB speed is.  Anyone know where I can find it?

Also, before I throw a bunch of money at this problem, has anyone else experienced problems with VS.Net like this?

Nick
Sunday, February 08, 2004

I don't have an answer for your particular problem with VS.NET, but a couple of comments:

1. Adding RAM is almost certainly not going to help. The fact that your CPU is saturated is completely unrelated to the amount of memory you have. Now, if the issue was that your hard drive was thrashing like crazy, then maybe you are paging a lot because you are out of memory - but that doesn't sound like the issue.

2. Inspecting the working set and pagefile usage of the processes on your system should confirm that the issue is not that you are running out of memory.

3. You should check what process is running the CPU up to 100%. If it's really an issue with VS.NET, it will probably be the devenv process.

4. Try using the performance monitor MMC snap-in to check what else is happening with the process in question: is it stuck doing file I/O? Spinning up large numbers of threads?

5. Using FileMon or RegMon (or similar utilities) to see what the process is reading and writing might give some clues.

6. Attaching a debugger to the process and trying to get a call stack (though you probably won't have debug symbols, so it might be tricky) or stepping through the code in the offending thread(s) might give some indication of where it's having problems.

Mike Treit
Sunday, February 08, 2004

By the way, if I had to guess, my first bet would be on a bug in your video driver...make sure you're fully patched and have up-to-date drivers for all your hardware.

Mike Treit
Sunday, February 08, 2004

Have you tried using AdAware or something similar to clean your PC ?

Maybe a small app like WinRam turbo will useful in clearing up memory...

I remember way back when using the beta documentation would steal all my memory - don't use the local MSDN help. Use Google instead... :)

Kentasy
Sunday, February 08, 2004

Regarding what kind of Dell you have - try support.dell.com and put in your five-letter product key (on the back or bottom of your PC). Alternatively, get SiSoft's Sandra which will tell you the FSB and should identify your current memory.

The BIOS should also tell you. :-)

Philo

Philo
Sunday, February 08, 2004

Definitely don't worry about extra RAM... VS 2003 ran adequately on my pokey laptop with 256MB.  Something's corrupted. 

Why not just do a reformat-and-reinstall-Windows?  Usually good for all that ails you.  (Insert snarky /. comment here. <g>)

Robert Jacobson
Sunday, February 08, 2004

I highly doubt its a hardware problem, more a VS.NET problem.

A re-install might or might not fix it, or possibly you can shut it down when you aren't using it.

Dan G
Sunday, February 08, 2004

Make sure you don't have any servers included in the Server Browser.  That thing is a stupid dog.

If you have a server in teh Server Browser behind a firewall that drops packets, prepare for agony.

The crappy thing is that you can't make it stay away.

Richard P
Monday, February 09, 2004

*  Recent Topics

*  Fog Creek Home