Fog Creek Software
Discussion Board




Maximized Internet Explorer?

How to make sure Internet Explorer opens maximized with "open link in new window"?

Lame, I know.

Alex
Thursday, December 04, 2003

1.- Close all Internet Explorer windows
2.- Open just one Internet Explorer window
3.- Maximize it
4.- Close it.
5.- Enjoy
6.- Blame if it doesn't work :)

.NET Developer
Thursday, December 04, 2003

It doesn't  :(

.NET Developer (test first, post later)
Thursday, December 04, 2003

I use MyIE2 which is freeware, uses IE and always starts maximised and starts new URLs on new tabs.

http://www.myie2.com/

The commercial alternative is NetCaptor, http://www.NetCaptor.com.

In fact, Adam Stiles of NetCaptor was the one that came up with the idea of tabbed browsing long before Mozilla, Opera and other browsers implemented it.

I feel sorry for Adam - had a gre8 idea, had it stolen by others. :-(

Jax
Thursday, December 04, 2003

> I feel sorry for Adam - had a gre8 idea, had it stolen by others. :-(

Oddly... Microsoft passed up the opportunity to steal his idea...

www.MarkTAW.com
Thursday, December 04, 2003

close the maximized window with Alt+F4,
win apps only remember their positions (at least IE) if you close it with double-click on left side icon, and not clickink on the right side X.

name not available
Friday, December 05, 2003

Right click your shortcut, Properties. In the shortcut tab there is a setting named Run, set that to Maximized.

Don Vince
Friday, December 05, 2003

This is the thing that _really_ bugs me about IE.

Yes, as most people have pointed at - you can get IE to open maximised using the shortcut properties.

However, I've searched fairly extensively and there's no way to make "Open in New Window" windows maximised as far as I can tell... the best you can do is resize the opened window to almost full size (but not maximised) so that following new windows open in a similar state. Its still not the same as maximised.

I just got used to hitting the following keyboard shortcuts every time I switch to an unmaximised window:

Alt + Spacebar, X

Gordon Hartley
Friday, December 05, 2003

>> best you can do is resize the opened window to almost full size (but not maximised) so that following new windows open in a similar state

... this used to work fine in Win98, in XP it doesn't...

Alex
Friday, December 05, 2003

>>> best you can do is resize the opened window to almost full size (but not maximised) so that following new windows open in a similar state

>... this used to work fine in Win98, in XP it doesn't...

Works fine for me (XP Professional). I think you had to do the ctrl+shift+double click the icon in the top left corner to get it to "remember" the window size setting. I can't remember whether you had to close the other maximised window first, but it definitely still works.

Gordon Hartley
Saturday, December 06, 2003

Gordon's instructions don't work on my XP Pro machine either, but I found a solution that works:

1.  Open Internet Explorer normally.  (Make sure no other instances are running.)

2.  Right-click on a link and select "open in new window."

3.  Resize the new window by dragging the borders so that it takes up the full screen.  (Do not click the "maximize" button.)

4.  Close the first window.

5.  Close the second (stretched) window by shift-clicking on the red "close" button.

As Gordan said, this isn't quite the same as a maximized window -- you'll still see the blue borders around the window.  I also couldn't find any way to get that, unfortunately.  This is a major annoyance.

Robert Jacobson
Saturday, December 06, 2003

None of the shift-click-close-whatever methods will really work; as soon as you get a small popup it'll screw things up.  The only permanent fix is some sort of IE wrapper like Avant browser.

Jason McCullough
Tuesday, December 09, 2003

How about creating an icon with the following path:

"C:\<path>\Iexplore.exe" "websitename.com"

Then, in this shortcut, changed the run as to maximized.  You will only need one copy of the icon for this.

c. adair
Friday, January 23, 2004

I HAVE A SOLUTION (trying to get your attention here).

For over three months, I've tried just about everything everyone told me.  But the annoying problem of opening maximazing windows could never get fixed.  Enter me one day, reading my PC World magazine, and BAM, I got a solution.  It's a small (VERY VERY small) program that loads when Windows starts up, and it has NO spyware or any of that stuff, it's FREE, and uses nearly no CPU power.

Check it out here:
http://www.jiisoft.com/iemaximizer/

Just trying to help,
-=MaStA ViC (Victor Ly)

MaStA ViC (Victor Ly)
Thursday, January 29, 2004


MaStA ViC (Victor Ly), u r the genius, u has solved the problem.

when doing research on yahoo, i always click SHIFT while clicking on links to open them in a new window, and when doing research, i usually open 5-10 window, and all those window that i open is not maximized, its frustated how i gotto maximized each and every window i opened

john west
Tuesday, June 22, 2004

*  Recent Topics

*  Fog Creek Home