Fog Creek Software
Discussion Board




Background defrag in XP.

Does anyone know how to disable this?  After my system is idle for about 15 or 20 minutes, the hard disk just goes nuts.  I've read that the cause is a background defragementation process, but I can't find how to disable it anywhere (not in the scheduled tasks, etc).  Thanks.

Luke
Wednesday, January 14, 2004

It's indexing. Go to Control Panel/Administrative Tools/Computer Management/services and Appliations/Indexing servive

Stephen Jones
Wednesday, January 14, 2004

There is a background defrag process (if you hit the task manager fast enough you can see it just before it goes away).

I've never found a way to disable it; but then I haven't looked very hard.  I have the indexing service turned off.

Almost Anonymous
Wednesday, January 14, 2004

Yep, you live and learn.

To quote from the XP Professional Resource kit,
"Win XP Professional optimizes the location of boot files and appliactions when the computer is idle.The optimization occurs in the background and lasts only a minute or two.......After the initial optimization takes place, subsequent optimization occurs, at most, every three days."

It still looks like the OP's problem is indexing though.

Stephen Jones
Wednesday, January 14, 2004

Nope, it's the fastboot optimizations, that sounds about right.  I always immediately disable the indexing.  Thanks for the help.

Luke
Wednesday, January 14, 2004

*  Recent Topics

*  Fog Creek Home