Fog Creek Software
Discussion Board




FTP problem in IE

Hello,

After some googling I have been unable to find a solution to this problem that Im having with ftping from IE.

IE passes username/password in the URL like this:

ftp://myuser:mypassword@foo.com

my problem is that the password Im asked to use starts with a # character, and some random charaters, which happen to make up the sequence #7b which makes for a valid hex code. This is escaped and replaced by another character in IE. Is there a way to preserve the characters without them being treated as 0x7b?

Aside from getting a decent ftp client, is there a way to solve this?

Thank you.

Patrik
Thursday, August 28, 2003

Have you tried URL encoding each character?

Mike
Thursday, August 28, 2003

Thank you.

URL encoding did work. Problem solved.

Patrik
Thursday, August 28, 2003

Another way:

ftp://myuser@foo.com

IE will prompt for the password (and give an option to save the password).

NoScript
Thursday, August 28, 2003

Have you looked in the File menu when FTP is the protocol. There should be a login command allowing you to specify a username and password to login to the site.

PaulT
Friday, August 29, 2003

PaulT,

Im using an old version if IE, still on NT4; so I have no FTP logon menu in the File menu. However, it worked with URL encoding, so Im all happy.

Patrik
Friday, August 29, 2003

*  Recent Topics

*  Fog Creek Home