Fog Creek Software
Discussion Board




HTTP/1.1 New Application Failed

HTTP/1.1 New Application Failed

Has anyone received this error on IIS 5.0 using ASP 3.0?  If so, would you mind sharing with me how you corrected it?

The host I use for my website says that my default.asp page is giving them this error.  It gives me an "HTTP 500 Internal Server Error".  I'm trying to troubleshoot the problem.  The forum has worked for 2 months without a glitch. 

- http://www.sswltd.com/forum.asp -

I have already deleted the global.asa file, checked for memory leaks and checked the connection string - all to no avail.

MSDN says this about the error on IIS 4.0:

http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q210/8/42.asp&NoWebContent=1

This post seems to indicate that it also occurs with IIS 5.0:

http://www.iis-resources.com/modules/newbb/viewtopic.php?topic_id=436&forum=3&jump=1

Unfortunaetly, I don't own or have access to the server and have to wait to have my site restarted.

Any tips would be appreciated.

Dave B.
Wednesday, June 18, 2003

I don't have any first-hand experience with this particular error, but here are a few suggestions:

It can be caused by an incorrect or corrupt global.asa - you already checked this file, but try it with an empty global.asa and also with no global.asa.

Have the ISP change the isolation setting from "medium" (if that's what it currently is) to either "high" or "low"

Have them make sure they created an "Application" for your virtual directory in IIS

I have seen suggestions that this error might be caused by not closing database connections and recordsets in your code; make sure you always call .Close (on both) after using an ADO recordset and connection.

There is also a possibility that this could be caused by overloading Access if that's what you're using as your database (but I think you would need a lot of concurrent activity before this became a problem


Also, in your browser (Internet Explorer), in Tools -> Internet Options -> Advanced tab; uncheck "Show friendly HTTP error messages" - this may show you more details of the error (although probably not with this particular type of error).

Philip Dickerson
Wednesday, June 18, 2003

Thanks for the informative reply Philip.

My web-host emailed me this morning and said they "fixed the problem" whatever that may have been...

Dave B.
Thursday, June 19, 2003

>> "My web-host emailed me this morning and said they "fixed the problem" whatever that may have been..."

That can best be summed up as, "We made a mistake and we're not going to own up to it.  While were at it we'll close the case so you can't email us about it and so we don't have to answer your questions."  I bet their service is poor too? and they direct you to sites other than their own that are suppose to provide "help" and "faqs". 

I really don't know why it's so difficult for companies to take responsibility for their mistakes.  Hey we screwed up this time, we're sorry.  And don't wait 12 hours before you get on the problem, handle it promptly.  This type of company I can handle.

Of course I'm just speculating what Dave's host is like, but you get the idea.


Thursday, June 19, 2003

*  Recent Topics

*  Fog Creek Home