Fog Creek Software
Discussion Board




Welcome! and rules

Joel on Software

Network disabled after installing VS2005 Beta2?

Has anyone encountered a problem with the network adapter not working after installing Beta 2 of Visual Studio 2005? I searched in Google and didn't find anything like this, and I also searched in the Visual Studio 2005 Forums, and found one entry from a person with a similar issue (but no responses so far in the forum):
http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=4233

The problem:
I installed Visual Studio 2005 Beta 2 (the download from MSDN) on my home system, and the network adapter is now "disabled" and cannot be enabled. (Worse, both Windows and Norton AntiVirus see this as a "significant hardware change" and require re-activation - even though the same network adapter is still there and visible to the operating system, and working properly according to the device manager, it's just not enabled).

The system is Windows XP Professional SP2 (with all the latest Windows updates); it has Visual Studio 2003, but has never had any previous beta versions of Visual Studio 2005 installed on it. I did a full install of VS2005 Beta2 and all appeared to be working, I was able to start Visual Studio, create a simple test web site based on the personal website starter kit and run the website locally. Then I decided to reboot and the network adapter was disabled when the system restarted, and Windows informed me that it needed to be re-activated within 3 days because of a significant hardware change. Attempting to re-enable the network adapter displayed a "Connection Failed" message box after several seconds and the network adapter remained disabled. There are no errors in the event log, and according to Device Manager, the network adapter is working correctly and there are no conflicts and no other hardware or device problems. The system has an ABIT IT7-MAX2 motherboard with a Realtek on-board network adapter.

I used "System Restore" to roll back to the state just before I installed VS2005 Beta2, and the network adapter became enabled and started working correctly again (although Windows still insisted it needed to be re-activated). I undid the restoration to effectively re-install VS2005 Beta2 and the network adapter became disabled again. I then un-installed individual pieces of VS2005 Beta2 (in what I think is reverse order of installation) until only the .NET Framework 2.0 was left, and the network adapter is still disabled.

Philip
Friday, April 29, 2005

For those who did not follow the above link:

http://www.sturmnet.org/blog/archives/2005/04/21/vs2005-beta2-networking-tpc-fix/

BillT
Saturday, April 30, 2005

*  Recent Topics

*  Fog Creek Home