Fog Creek Software
Discussion Board




Welcome! and rules

Joel on Software

VS keyboard shortcuts and frustrations

I know if you click on a function or sub name and press F12, it will jump down to the function definition.

How do you get BACK automatically?? I've tried everything that seemed obvious.

(I use the VB.NET with the keyboard setting on {Default}, if that makes a difference)

One more VS annoyance, and wondering if there is a way to turn it off:

Put your cursor at the start of an indented line of code inside a function. (right before the first character, not at the left margin) Now press Enter.
It does insert a blank line, but it also moves your cursor 6 characters to the right, so that it is no longer at the beginning of the statement. If you press Enter again, you've now busted apart the line of code at a strange place.

Huge, huge frustration when you want to insert 3 or 4 lines, and you end up mangling your code. Any solution to this?

BradC
Wednesday, December 08, 2004

For the back thing, click "Navigate Backward" on the toolbar, or use the default key combo: Ctrl-Shift-F2

Kyralessa
Wednesday, December 08, 2004

Actually, I use VB keys, so your settings might be different, but go to Tools > Options > Environment > Keyboard to check; start typing in NavigateBackward under "Show commands containing" to see what it is.

You're right about the indent thing; odd behavior, I must agree.  You might want to go to...

http://lab.msdn.microsoft.com/vs2005/get/order/default.aspx

...and get the beta for VS1 and see if it still does that.  If so, you might go to...

http://lab.msdn.microsoft.com/productfeedback/

...to log a suggestion of some other behavior.  (Personally, I'd never noticed it before.)

Kyralessa
Wednesday, December 08, 2004

Cool. Never knew that button was there.

Now that I know what its called, I can see that the default shortcut on the View Menu is "Ctrl+-"
Ctrl-Shift-F2 only works in VB6 mode.

Any ideas about the other problem?

BradC
Wednesday, December 08, 2004

Yep I agree with that it is whacky the way the cursor gets indented after entering a newline. Anyone got a fix for this? This is VERY annoying...

Jon Simpson
Wednesday, December 22, 2004

You can turn off the automatic indenting:

TOOLS > OPTIONS > TEXT EDITOR > BASIC > TABS

and set Indenting to "None"...

not sure if this works for C++, C# or J#, but it turns it off in VB...

lobster
Wednesday, December 29, 2004

*  Recent Topics

*  Fog Creek Home