Fog Creek Software
Discussion Board




Welcome! and rules

Joel on Software

debugger problem vs.net 2003

Anyone here ever get the infamous---------------------------
Error while trying to run project: Unable to start debugging on the web server. The project is not configured to be debugged.

Click Help for more information.
---------------------------
OK  Help 
---------------------------

error message with vs.net 03?  I made a few additions to my web.config file and now, added a few extra pages to my project and now the thing keeps giving me that message.  I try to run without debugging and i get no errors on the web.config file, so I'm not sure if it is my web.config file.  I don't think it has anything to do with IIS settings, because for the last couple weeks i have not had any problem running the debugger and used often.  The web config file changes i made were to the authorization and authentication parts.  I've tried every peice of advice i've come across with no luck.

grover
Tuesday, October 26, 2004

and yes, debug=true in the web config file

grover
Tuesday, October 26, 2004

One thing I usually do is blow away all the cached project stuff that VS.NET/.NET creates.  You can find it all in:

C:\Documents and Settings\[USER_NAME]\VSWebCache

and

C:\WINDOWS\Microsoft.NET\Framework\[FRAMEWORKVERSION]\Temporary ASP.NET Files

I usually:

1) close solution
2) run iisreset
3) delete cache items
4) reboot

...and sometimes everything is fine.  Otherwise, the most common thing I've seen is that you have malformed xml in your web config but if you can run it without debugging that would debunk that theory.  The only other thing  is that if your startup URL for debugging does not match an IIS served page you'll get that error.

Good luck.

smallbiz
Tuesday, October 26, 2004

Yes, got that one today, as a matter of fact. Just set your web app up in IIS as a virtual web app: Go to control panel, administrative services, Internet Information Services (IIS). Expand the Default Web Site tree, and in the right pane, find your app. Right-click on it, choose Properties, and in the Application Name box, type in the app name and save. See if this will fix the problem.

SongSing Writer
Wednesday, October 27, 2004

it actually ended up being my webconfig file, i commented out my location tag and the debugger started working again. 

grover
Thursday, October 28, 2004

*  Recent Topics

*  Fog Creek Home