Fog Creek Software
Discussion Board




Welcome! and rules

Joel on Software

PIA version problem

I've created a PIA for a COM object that is used by a .Net solution using tlbimp/sn under VS.Net 2003.  The deployed assembly works fine on .Net 1.1, but I get a "Strong name validation failed for assembly" when running on .Net 1.0.

This all used to work (!?) before I started using tlbimp/sn to create a PIA (which is kinda required, given that this is a comml product).

Any suggestions would be appreciated.  Thanks.

BillT
Tuesday, August 31, 2004

Hi Bill,
if I'm not misstaken strong names are not backward compatible. You you are faced with some options:
1) Make .net 1.1 mandatory
2) Recreate (a second set) the PIA using the 1.0 framework
(smells like NANT to me: a built process compiling 2 different exe)
3) Consider linking the framework into the exe (We use thinstall.com for that and are happy both with the product AND the support).
Hth
:-) stw

Stephan H. Wissel
Tuesday, September 07, 2004

That's what I thought originally too, but that turns out not to be the case.  The interoperability problem was apparently elsewhere (not sure where at this point), but it does seem that a PIA created w/VS.Net 2003 and .Net 1.1 is backward-compatible w/.Net 1.0.

It sure would be nice if this were documented somewhere.

BillT
Wednesday, September 08, 2004

*  Recent Topics

*  Fog Creek Home