Fog Creek Software
Discussion Board




simple url format...

the simple url format is used in the fogbugz email sent when a new issue is created. for me it looks something like:
http://www.company.com/fogbugz/?319. when i open this link in IE6 it doesn't go to the bug page for 319. it just leaves me at the welcome page.
- I'm logged in
- IE6, winxp pro
- just upgraded to fogbugz 3.0.5

am i going insane?

JN
Tuesday, November 19, 2002

So http://www.company.com/fogbugz/?319 doesn't work but
http://www.company.com/fogbugz/default.asp?319
does?

Michael H. Pryor
Tuesday, November 19, 2002

correct. 

here is a bit more information on our system -

running NT small business server 4.0 with the latest service pack.

IIS 4 (perhaps this is the problem?)

JN
Wednesday, November 20, 2002

ahh... interesting... I will look into this.

Joel Spolsky
Thursday, November 21, 2002

I investigated and discovered that you're right -- NT 4.0 with IIS 4.0 doesn't allow the /?123 shortcut.

This bug will be fixed in the next incremental release (3.0.7).

Joel Spolsky
Thursday, November 21, 2002

I just upgraded to 3.0.13 and the short url still does not work. is there anything else I need to do?

btw, is there a page that has a list of changes included in each new FB version?

JN
Tuesday, November 26, 2002

The fix was to change the URLs so they no longer are in the short format.  They all include default.asp now.

So your old notification emails won't work.  But all future ones will.

You can find our minor changes on the Online Support section of http://www.fogcreek.com/FogBUGZ/

Michael H. Pryor
Tuesday, November 26, 2002

*  Recent Topics

*  Fog Creek Home