Fog Creek Software
Discussion Board




mailbox acct with attachment > ~45K not pulled

I have a mailbox set up, and the Upload File Size Maximum under Site is set to 100000K.  I've sent multiple emails to the mailbox account with varying size of file attachments.  It seems that at around 45KB, the email isn't pulled into the bug tracking database.  Any email with an attachment < 45KB is received and I can list the bugs and see it.

Lee Hamel
Friday, November 19, 2004

I'm using FogBUGZ v3.1.9.  I also followed the directions in the DartMail update.  Running Windows Server 2003 and IIS 6.0.

Lee Hamel
Friday, November 19, 2004

What happens if you just upload a file (attach it to a case) that is a big file?  Does that work?

Michael H. Pryor
Fog Creek Software
Friday, November 19, 2004

Should also note that the emails that didn't get pulled into FogBugz (those with attachment >~45KB) were sent.  I used Outlook Express, and it downloaded those messages.

I also called Fog Creek Tech Support and they mentioned UploadReadAheadSize in the IIS 6.0 file \windows\system32\inetsrv\MetaBase.xml.  This entry wasn't in the file, so I put it under the IISWebService section.  Had to use Google to find out what section, and Microsoft web page says to put it there.  I put the line UploadReadAheadSize = "1073741824".  This is decimal equivalent of 0x40000000.  Fog Creek Windows Knowledge Base, What Setup Does, IIS Settings, suggests this value.  In order to change the MetaBase.xml file, I had to run IIS Manager, right-click on my computer, choose Properties, then check off "Enable Direct Metabase Edit".

Lee Hamel
Friday, November 19, 2004

I created a New Case, hit the Browse button to attach a file that is 264KB, click OK, and get this error:

There was an error with your request. Please fix the problem described below and hit back to resubmit your request.
Your bug was NOT submitted. Please hit back and resubmit your bug.: 006~ASP 0175~Disallowed Path Characters~The '..' characters are not allowed in the Path parameter for the MapPath method.

Lee Hamel
Friday, November 19, 2004

I get the above error regardless of size of attachment.  Even a 714 byte attachment gave me that error.

Lee Hamel
Friday, November 19, 2004

Did you run setup to install FogBugz or did you try to install it manually?

The reason I ask is because setup does all of these things for you, like setting the UploadReadAheadSize, etc.  including this next part:

You need to go into the properties for your fogbugz virtual directory.  On the virtual directory tab hit the 'Configuration' button.  Then on the options tab in that dialog select the 'Allow parent paths' checkbox and save it.

Michael H. Pryor
Fog Creek Software
Friday, November 19, 2004

I ran the FogBugz setup EXE file.  The "Allow Parent Paths" checkbox wasn't checked.  After checking it, I can add a New Case with attachments up to about 230KB now.  After that size, I get the following error:

There was an error with your request. Please fix the problem described below and hit back to resubmit your request.
Your bug was NOT submitted. Please hit back and resubmit your bug.: 007~ASP 0104~Operation not Allowed~

Lee Hamel
Friday, November 19, 2004

The 200KB attachment that got through via adding a New Case didn't get through when I emailed the mailbox account.  Sounds like I have multiple installation errors.

Lee Hamel
Friday, November 19, 2004

Well, it's definitely related to this:

http://www.fogcreek.com/FogBUGZ/KB/errors/OperationNotAllowederroru.html

I know you set that but you may not have set it in the correct place.  Make sure it's set for every place it occurs in the xml file (particularly in the FogBugz application section)

The FogBugz setup should do all of this for you though.  Have you tried reinstalling?  And choosing upgrade?  Or installing to a new location?  Something is ill in your IIS installation, unfortunately, ... you shouldn't have to do all of this manually.

Michael H. Pryor
Friday, November 19, 2004

Oh, and the reason why the attachment goes through the web interface and not through email is because the email mechanism encodes the attachments differently before uploading them, so they will be slightly larger via email.

Michael H. Pryor
Friday, November 19, 2004

I reinstall FogBUGZ-Setup-319.exe and the following happened:

1. Program Files\FogBUGZ was renamed to FogBUGZ.1
2. Program Files\FogBUGZ was created.
3. FogBUGZ has a FileUploads dir in it, while FogBUGZ.1 doesn't.
4. The DOC and ZIP attachments that I could never get through got through!  They are 260 KB.

Any way to figure out what happened?

Lee Hamel
Friday, November 19, 2004

> 1. Program Files\FogBUGZ was renamed to FogBUGZ.1
Correct.  The upgrade backs up your current FogBugz install to FogBugz.X (where X is the next available number)

> 2. Program Files\FogBUGZ was created.
Correct.  FogBugz upgrade creates a new install directory to put the files in.

> 3. FogBUGZ has a FileUploads dir in it, while FogBUGZ.1 doesn't.
Again, this is expected.  The upgrade moves the FileUploads folder from your old install to your new install.

> 4. The DOC and ZIP attachments that I could never get through got through!  They are 260 KB.
Yup, sounds right to me!

> Any way to figure out what happened?
I honestly have no idea, but due to the complexity of Windows I've seen about 1% of machines just do crazy stuff like this.  It could be because of some service pack or the version of IE you have, or maybe IIS itself.  I'm glad it's working now though :)

Michael H. Pryor
Friday, November 19, 2004

Appreciate you posting back and forth with me until it was solved.  I needed to get this working so I don't have to come into the office as much, and more importantly so other engineers and customers can submit bugs to our support email address.

Lee Hamel
Friday, November 19, 2004

No problem... that's why we're here on Friday night at 9pm in the middle of manhattan. 

Yikes! I need to go home so I can go out tonight :)

Michael H. Pryor
Friday, November 19, 2004

*  Recent Topics

*  Fog Creek Home