Fog Creek Software
Discussion Board




Cookies become invalid when switching

Hi

I wonder if someone can help;
We have a bug tracking system and a support system using two instances of FogBugz. When switching between them I cant log in, it just loops at the login page, or when moving from our intranet site to either instance of FBz, I get the message "cookies have been disabled", and then it loops at the login page. I have to start a completely new browser session ( I assume to get a new cookie) in order to sucessfully login. I have trawled the other help and forums and tried most of the suggestions, but to no avail.

I want our staff to be able to click on a link in the intranet an have it take them to FBz successfully (I also tried the '_Blank', in the link to open a new window - result was the same).

Any help appreciated, Thanks - RL

Roland Lockhart
Tuesday, November 16, 2004

This is because we log you on, but your logon is associated with a database ID.  So when you go to the other site, it sees your database ID and it doesn't match so it doesn't log you on.  You would either have to a) clear your cookies or b) log off, before you could log on successfully.

All you need to do is give the two sites two different DNS names.

Tell me briefly what their URLs are now, and I can help you figure out how to arrange them to get it to work.

Michael H. Pryor
Fog Creek Software
Tuesday, November 16, 2004

Hi michael

Thanks for your help.
I did some testing with the URL's
After adding http://intranet to 'allowed cookie handling' in IE and logging off between switches, I seem to be able to switch between FBz instances OK now. But, I cant switch (read 'jump')from http://intranet/ngis (ASP)  to http://intranet/softwaresupport (FBz), it still just loops at the login page.
Ta - RL

Roland Lockhart
Tuesday, November 16, 2004

That's odd, because the cookie should be set on the path /ngis not on the root domain, so one virtual directory shouldn't see cookies from the other (at least in IIS, apache may screw this up).

But a quick fix is just to give your machine another additional DNS name, or reference one of them by IP instead on DNS name, so their url's don't share the same hostname.

Michael H. Pryor
Fog Creek Software
Tuesday, November 16, 2004

Thanks Michael

The fix was to change the link in the intranet pages from 'http://intranet/softwaresupport' to 'http://192.168.0.210/softwaresupport'

Its actually not that desirable, but without a better way it will have to be it. Can I tell the browser to drop a cookie in the link URL, or is there an IIS setting that might not be correct for this?

Roland Lockhart
Tuesday, November 16, 2004

*  Recent Topics

*  Fog Creek Home