Fog Creek Software
Discussion Board




Weird problem

Hi,

After moving my FogBugz installation from a WinXP box on my network to a Win2k box I get a message that says that "my browser does not support cookies". I haven't changed any settings on my browser.

Any ideas what I did wrong?

Kevin

PS. I can log into the system, but I immediately have to relogin every time I do something

Kevin Moore
Tuesday, July 27, 2004

The old site was probably in your trusted sites in IE.  Disable any virus/firewall software you have and try again after adding the new fogbugz server to your trusted sites under Tools->Internet Options

Michael H. Pryor
Fog Creek Software
Tuesday, July 27, 2004

Michael,

I have tried altering a number of settings but I still am having no luck. I didn't find my original machine in any trusted sites. Any ideas?

Kevin

Kevin Moore
Tuesday, July 27, 2004

Have you tried using a different browser?

Have you searched your cookies to see if they are being set?  If the cookies are not there, then something on your computer is preventing them from being set...

Are you checking the remember me checkbox?

Michael H. Pryor
Fog Creek Software
Tuesday, July 27, 2004

Michael,

I have both servers active and running.

I will connect to the old box and everything works fine. When I connect to the new box I get a red message below the login screen that says

"Your web browser does not support cookies, or you have disabled them. FogBUGZ requires cookies to keep you logged on."

Both are running in my "local intranet" zone and I don't understand what I could have done to turn off cookies on one site and not the other.

Kevin

Kevin Moore
Tuesday, July 27, 2004

Ok, but I need you to tell me about the questions above before I can even guess as to what is going on...

Michael H. Pryor
Fog Creek Software
Tuesday, July 27, 2004

Actually, even without those answers I could venture a guess that you don't have the licenses installed on the second installation of FogBugz and you aren't logging on as an Administrator. 

If you don't have enough licenses and you don't log on as an administrator, it won't let you log on (although you should get a warning about that.)

Michael H. Pryor
Fog Creek Software
Tuesday, July 27, 2004

Are you using SQL Server and did you move your database? If so, you need to make sure the login you're using in the database is db owner for the FogBugz database:

http://www.fogcreek.com/FogBUGZ/KB/trouble/StayLogged.html

Also, here's a guide to moving FogBugz, do be sure you've covered all the bases, to head off any other problems in the future, related or not to this current issue:

http://www.fogcreek.com/FogBUGZ/KB/howto/MoveFogBUGZ.html

Dmitri
Fog Creek Software
Tuesday, July 27, 2004

Definitely try it with mozilla and from another computer.

To check if cookies are being set in IE, go to Tools -> Internet Options. Click the Settings button, Click the View FIles button, sort that window by name.

Look down for the files named Cookie:[yourname]@theserver.com and see if the cookies are there.

In Mozilla this is much easier, as they have a control panel that shows you the cookies under Options.

Michael H. Pryor
Fog Creek Software
Tuesday, July 27, 2004

Well,

If I delete everything out of the Temporary Internet Files folder and then connect to the old server, I see a cookie for my User and everything looks good.

If I connect to the new server, I don't see the cookie, I see everything else but not the cookie for the new server.

I'll try and download Mozilla and see what happens.

Kevin Moore
Tuesday, July 27, 2004

Latest update.

I installed Mozilla and was able to connect with no problem to both the old and the new server. It appears that there is something I have done with IE connecting to the new server.

I'll have to do some more research because I don't really like the look and feel of mozilla and, as a first impression, it seems slower than IE.

If you guys think of something let me know.

Kevin

Kevin Moore
Tuesday, July 27, 2004

It seems to me that Michaels' first response was correct. The new server is not trusted by IE, the old one is. Mozilla is not having an issue with trust for either.

It's just a security setting in IE.

Please try this:

Privacy Tab > Edit (Web Sites) > add your new FogBUGZ server to the Allow list

Add it by domain.name.com, and also by IP address

Dmitri
Fog Creek Software
Wednesday, July 28, 2004

*  Recent Topics

*  Fog Creek Home