Fog Creek Software
Discussion Board




2 Issues: Escape quotations and email replys

I've found 2 minor issues:
--------------------------------------------------
First: whenever an item is placed in database that has a single quotation mark, I'm assuming that it is escaped out.  The unfortunate thing is that the escape character is not being removed during a SELECT from the DB.  So as I'm using email, fogbugz keeps adding more escape characters, like this:

I\'m attempting to deactive the Death Star's Core.. Please be patient young Skywalker.

-----Original Message-----
From: \"Jim Pringle\" <XXXXXX@yahoo.com>
Date: Tue, 29 Jun 2004 13:17:22 -0700
To: \"\'ZephyrSky Support\'\" <XXXXXX@zephyrsky.net>
Subject: RE: (Case 20) It won\\\'t work

Well, nothing is happening!!

-----Original Message-----
From: ZephyrSky Support [mailto:XXXXXX@zephyrsky.net]
Sent: None
To: XXXXXX@yahoo.com
Subject: Re: (Case 20) It won\\\'t work

We\\\'ll get on it right away

-----Original Message-----
From: \\&quot;Jim Pringle\\&quot; &lt;XXXXXX@yahoo.com&gt;
Date: Tue, 29 Jun 2004 13:10:44 -0700
To: &lt;XXXXXX@zephyrsky.net&gt;
Subject: It won\\\'t work

Well, will you fix it?
--------------------------------------------------

Second issue has to do with replying to an incoming email case.  The incoming email address looks like this:
"Jim Pringle" <XXXXXX@yahoo.com>

But if I reply to that I get this:
[pear_error: message="unable to send data" code=0 mode=return level=notice prefix="" info=""]

It will work if I have only the email address in the To: box without the Name title:
XXXXXX@yahoo.com


That's it.. sorry for the long post.  Fogbugz rocks!

Jim Pringle
Tuesday, June 29, 2004

Please send an email to customer support:

https://shop.fogcreek.com/mail/

Please mention that you posted this here, you do not have to paste in all that text into your email, support staff can see it here. Thanks.

Dmitri
Fog Creek Software
Tuesday, June 29, 2004

(For anyone reading this post in the future:)

The slashes is because you probably have magic_quotes_gpc turned on which does this.

http://ca2.php.net/addslashes

And it is probably related to the mail problem also...
php is changing

"Jim Pringle" <XXXXXX@yahoo.com>
to
\"Jim Pringle\" <XXXXXX@yahoo.com>

and the mail functions don't like that.

install1.php should have warned you about this.

You can change this setting in your php.ini file.

Michael
Fog Creek Software
Tuesday, June 29, 2004

*  Recent Topics

*  Fog Creek Home