Fog Creek Software
Discussion Board




E-mail not coming through.

I'm having troubles getting a (large - 5Meg) email into
FogBUGZ. The system shoots up to 100% for 5 minutes, and then fails trying to upload the message into the
database.

I'm currently using MySQL as the backend database on  Win2000, with IIS as a the web server (same machine).

I've had this problem before:
    http://discuss.fogcreek.com/FogBUGZ/default.asp?cmd=show&ixPost=3469

I've checked the 'max_allowed_packet'  variable (I've even
tried upping it to 100M to see if that would work). The relevent section of my 'c:\my.cnf' file appears below

--start--
# The MySQL server
[mysqld]
port=3306
#socket=MySQL
skip-locking
set-variable    = key_buffer=16K
set-variable    = max_allowed_packet=100M
set-variable    = thread_stack=64K
set-variable    = table_cache=4
set-variable    = sort_buffer=64K
set-variable    = net_buffer_length=2K
server-id    = 1
--end--

I've also double checked the settings in the DataSources (ODBC). They all seem to mach the documentation.

I've also checked the 'S' column in the BugEvent table is
set as a longtext field.

Are there any other suggestions as to what might be going on?

Sean Ennis
Monday, June 07, 2004

On some machines (RedHat 9 notably), PHP files are set to limit uploads to 500k.  Look for a file called php.conf in your httpd/conf.d directory.  If there is a value called LimitRequestBody, set it to 0 (meaning unlimited).  If you cannot upload files over 500k, this is why.

Michael H. Pryor
Fog Creek Software
Tuesday, June 08, 2004

My Win2000 box does not seem to have any PHP files in the C:\Program Files\FogBUGZ directory.

Nore does the machine have an httpd/conf.d direcotry.

Is there a way that I can verify that MySQL is taking the value I'm supplying for the max_allowed_packet variable?

Sean Ennis
Tuesday, June 08, 2004

Sorry.  That was for Apache, not IIS.

For IIS, go to the Internet Services Manager control panel, right click on the fogbugz virtual directory and choose properties.  Look for the configuration button ( on the virtual directory tab).  In the Application Configuration dialog that pops up, go to the Options tab and increase your ASP timeout to like 900 seconds or more.  That should take care of it.

Michael H. Pryor
Fog Creek Software
Tuesday, June 08, 2004

*  Recent Topics

*  Fog Creek Home