Fog Creek Software
Discussion Board




emailed bugs failing with network error

FogBugz normally works fine. We use it to create/assign/resolve/close bugs and it emails us at the appropriate times. But, for some reason it won't receive bugs via email.  I've set up a mailbox via the "Mailboxes" menu, but according to the logs it appears it fails at the point where it tries to create the bug. Here are part of the relevant log messages:


CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail...
CheckMail executing...
SOFTWARE\Fog Creek Software\FogBUGZ\C:/Program Files/FogBUGZ/website\dispatcho
Reading user,pass,server,port,url
bugs
<PASSWORD HERE>
mail.snowball.com
110
http://fogbugz.ign.com/fogbugz/dispatcho.asp?ixMailbox=3
Setting normal (non-secure) mode
Attempting to log in
Connected...
Num Messages...
31
Publishing...
31
Com Error in PublishMessageToURL: The connection has been dropped because of a network failure or because the peer system failed to respond. Also caused when Connect, Send, Receive, Fill or Close  methods are used with a Timeout parameter and the operation fails to complete within the specified numb
er of milliseconds.
Error: PublishMessageToURL returned False. ASP file did not return 'OK'
Publishing...
30
Com Error in PublishMessageToURL: The connection has been dropped because of a network failure or because the peer system failed to respond. Also caused when Connect, Send, Receive, Fill or Close  methods are used with a Timeout parameter and the operation fails to complete within the specified numb
er of milliseconds.
Error: PublishMessageToURL returned False. ASP file did not return 'OK'
Publishing...
29

Geoff Fortytwo
Tuesday, May 18, 2004

Hey! We were just talking about you:
http://discuss.fogcreek.com/FogBUGZ/default.asp?cmd=show&ixPost=3775&ixReplies=4

Are you using Secure POP3?  If so, you must log into the server as FogBUGZ and THEN install your security certificate.  You can make sure this is correctly installed by running Outlook Express when logged on as the FogBUGZ user.  You should not be prompted when you connect to the mail server.  If you are prompted (about whether to trust the certificate or not), the security certificate is not properly installed.  (Rebooting the system may be what's needed.) 

Dmitri
Fog Creek Software
Tuesday, May 18, 2004

I asked a network guy and he said we're not using secure pop:  "we are not using secure pop;just regular pop3.  i can telnet to port 110 on mail.snowball.com"

Geoff Fortytwo
Tuesday, May 18, 2004

I bet you changed the DNS name of your FogBugz server or something like that...

Go into the mailboxes screen and check for the mailbox that the FogBugz URL is actually correct!  You should be able to go to that URL in your browser (you probably get a 500 error, but as long as you don't get a 400 error when you visit that page.  In other words, it IS found, but it will not work right when you visit it through the browser.. That is expected).

Michael H. Pryor
Fog Creek Software
Tuesday, May 18, 2004

*  Recent Topics

*  Fog Creek Home