Fog Creek Software
Discussion Board




No indexes on certain fields?

We were seeing some absurdly slow performance with "FogBugz Version 3.1.9 (DB 328)" on NT on MySQL... page loads for showing a bug by number were taking 5 seconds (!).

So I started poking around in the database, and playing with "log_slow_queries", and found that in the BugEvent table, the ixBug field doesn't have an index.  Added an index to that field and the dt field, and the queries go MUCH faster now!

What I'm wondering is if FogBugz ships with indexes on the logical fields.    If so, then when we migrated FogBugz from one machine to another, we obviously screwed something up (losing the indexes).  If that is the case, where could I get a list of all the indexes in the database, so I can recreate them (and make the users swear a little less at FogBugz)?

Matt
Monday, May 17, 2004

That's the only one currently (the index on the ixBug field in the BugEvent table).  It's in the mysql.sql file that gets shipped with FogBugz but since 3.1.9 mySQL isn't created by the installer, it is always a user import procedure.  So indexes and the like aren't always created correctly.  The next version of FogBugz will allow you to install a fresh mySQL database so from the beginning your indexes will exist.

Michael H. Pryor
Fog Creek Software
Monday, May 17, 2004

Within the FogBUGZ download @2004-05-27 (FogBUGZ-Setup-319.exe) the distributed mysql.sql file creates an index for table BugEvent column ixBug for MySQL. However, there is no similar index in the distributed all.sql file for SQL Server.

Paul Bond
Thursday, May 27, 2004

*  Recent Topics

*  Fog Creek Home