Fog Creek Software
Discussion Board




Converted to NTFS, now no access

Sure, I can log on but can't do anything with the database. BTW, with an XP machine standalone, where the hell are the file/folder permissions?

File:  /CFilter.asp 
Line:  488 
Error:  Cannot update. Database or object is read-only. 
Browser:  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322) 
Number:  0x80040E09 
Category:  Microsoft JET Database Engine 
Column:  -1 
QueryString:  pg=pgList&pre=preLoadFilter&ixFilter=25 
URL:  /default.asp 
Content Length:  0 
Local Addr:  81.187.45.234 
Remote Addr:  81.187.45.234 
Time:  2/24/2004 00:07:32 

Mike MacSween
Monday, February 23, 2004

Provided its XP pro, you have to go into folder options and look under advanced for something called "Simple Sharing".  Turn that off.  Now you will get the Security tab when you do permissions (and permissions is where you need to go to give the fogbugz user full perms on all the files and folders under c:\program files\fogbugz).

Michael Pryor
Fog Creek Software
Monday, February 23, 2004

Thanks Michael. I figured out it was a permissions thing but couldn't see why the 'standard' NT permissions box was unavailable.

Mike MacSween
Tuesday, February 24, 2004

Just as an aside, this may not ever be relevant to you.

MS posted a knowledge base article entitled  "Compacting File Resets NTFS Permissions" referring to Access (i.e. JET) databases. I don't even know if FogBugz does a compact on the db or whether it's done manually. However, I can see it biting someone, somewhere using NTFS in the future.

http://support.microsoft.com/default.aspx?scid=kb;en-us;295234

Anon
Thursday, March 18, 2004

*  Recent Topics

*  Fog Creek Home