Fog Creek Software
Discussion Board




License confusion

We are intermittently getting messages from FogBUGZ about not having enough licenses. Usually, if we hit refresh then the page we trying to get to is successfully loaded. However, it is rather annoying. Here is what the licenses page in FogBUGZ says:

License for Steve Hales: 10 named users on TOLTEC (S-1-5-21-2066496780-1167936233-1435325219) purchased on 12/16/2003 - Order #4021371 [in use]
License for Steve Hales: 5 named users on TOLTEC (S-1-5-21-2066496780-1167936233-1435325219) purchased on 12/17/2003 - Order #4030649 [in use]
License check passed: You have licenses for 16 named users.  There are currently 11 named users active.

What is the problem?

Steve Hales
Monday, February 16, 2004

Your server is probably windows 2003 and you aren't running the latest version of FogBUGZ 3.1.9.

You can upgrade at https://shop.fogcreek.com with your order ID.

Michael H. Pryor
Fog Creek Software
Monday, February 16, 2004

FogBUGZ is running on an XP Pro machine and we are using Access as our back-end database. The database resides on our file server running NT 4.0. Also, we are running version 3.1.9 (DB 328).

Steve Hales
Tuesday, February 17, 2004

Ack! I wasn't even close.

Ok, then I think what might be going on is you could have NT Authentication checked somewhere in your web tree where fogbugz is the virtual dir.  Check in IIS, properties for the fogbugz node, directory security tab.  NT Authentication should NOT be checked.

Also, hit that anonymous access button there and check what user fogbugz is running as.  Make sure the user has full perms on the entire fogbugz folder (when you set the security settings, click advanced and check off reset all child properties).  Also for c:\winnt\temp or c:\windows\temp (wherever $TEMP is pointing).

Michael H. Pryor
Fog Creek Software
Tuesday, February 17, 2004

I looked at the properties for the FogBUGZ node in IIS. I do not see a check box for NT Authentication on the Directory Security tab. Please note that I am a newbie at IIS stuff. We just turned it on for FogBUGZ. I did click on the button to edit anonymous access and authentication control. In that dialog anonymous access is enabled. In this same dialog are some checkboxes under the heading of authenticated access. None of them are checked. I looked at the permissions for the FogBUGZ directory and the anonymous user (named "FogBUGZ") has Full Control for that directory and all of its subdirs and files. That user also has Full Control for the directory on our file server where we put the Access .mdb file.

Steve Hales
Tuesday, February 17, 2004

Doh!  I'm glad you said that last part.. otherwise I would have been shaking my head.

If your access db is on a file server, the connection through Jet isn't working 100%.  Those times when it can't reach the database it says it has no licenses because it can't read from the file.  When the network is flaky, it looks like there are no licenses because fogbugz can't read anything from the database file.

One way to remedy this is to move the mdb file to the local machine.  Another is to use MySQL or MSSQL if you have to have your database on another machine.  A third alternative is to map a network drive to the file share and in the site page where you put the path to the file, use the network drive name (ex: z:\foo.mdb) instead of (\\fileserver\foo.mdb)

Michael H. Pryor
Fog Creek Software
Tuesday, February 17, 2004

*  Recent Topics

*  Fog Creek Home