Fog Creek Software
Discussion Board




Email lost

I have FogBUGZ set up to retrieve email from our support email address.  It was working fine until today.  It stopped retrieving messages, and it hasn't gotten any all day today.  I restarted the computer, and FogBUGZ then retrieved 4 out of the 30 waiting messages and then deleted everything!  It only entere 4 of them into the database, and the remaining 26 are completely gone (not on the mail server or in FogBUGZ).

This is completely unacceptable.  Please let me know what you need from me to fix this.  Please contact me by email.

Tim

Tim Norman
Friday, November 14, 2003

Thanks for your excellent telephone support.  I think we've got the problem fixed (bad interaction with Norton Antivirus).

Tim

Tim Norman
Friday, November 14, 2003

We discovered that Norton Antivirus, working at the TCP/IP layer had been intercepting email and trying to remove viruses.  Since dispatcho runs as a service when Norton prompted it to acknowledge that a virus had been removed (or it had problems removing it), there was nowhere for the dialog to go.  So Norton was blocking on the dialog waiting for an answer and dispatcho was blocking on that waiting for its packets.  This made it seem like dispatcho had stopped.  Then the machine was rebooted and the packets that Norton had queued up were lost.  We'll look into this more and try to figure out why the emails got deleted.. there are checks in dispatcho to never do this unless it is ABSOLUTELY positive the email made it into the database.  Turning on email scanning on the fogbugz server resolved the problem.

Michael H. Pryor (fogcreek)
Friday, November 14, 2003

*  Recent Topics

*  Fog Creek Home