Fog Creek Software
Discussion Board




Any problem with .log attachments?

Folks,

  Every time I attach a .log extension file into FB, it does not allow me to download it. An error occurs when clicking in the attached file link (after it was attached):

"The page cannot be found"

  Any idea?

Thanks,

Alexandre B. Corrêa
Tuesday, April 01, 2003

I'm not aware of any problem.  I couldn't reproduce it here.

Michael H. Pryor
Tuesday, April 01, 2003

What's the full filename?

Michael H. Pryor
Tuesday, April 01, 2003

I have tested with many filename... here we have some samples:

- test.log
- _navcclt.log

Maybe is this a security issue from the server? (I'm guessing)

Alexandre B. Corrêa
Tuesday, April 01, 2003

Hi Michael,

  Any ideas? This problem is getting me nuts!

Thanks

Alexandre B. Corrêa
Friday, April 04, 2003

Did you check the IIS settings to see if it may be a security setting on the server?

I'm stumped honestly... I'm not sure how to reproduce the problem.

Michael H. Pryor
Friday, April 04, 2003

I found the problem: there's a conflict running IIS/FB and URLScan. Uninstalling URLScan solves the problem.

Alexandre B. Corrêa
Tuesday, April 08, 2003

Andrea,

I would recommend against uninstalling URLScan as it's helps to secure your MS IIS server. 

You can just change settings allow for .log extensions to be downloaded.  Go to URLScan.ini and add .log to the AllowExtension section or remove it from DenyExtension (depends on which one you have it set to check).

It's well-documented in the URLScan help files, but I'd be happy to help. 

Karan
Tuesday, April 08, 2003

Thanks!

Alexandre B. Corrêa
Tuesday, April 08, 2003

*  Recent Topics

*  Fog Creek Home